dev-ros/poco_vendor: initial import
authorAlexis Ballier <aballier@gentoo.org>
Thu, 12 Dec 2019 16:22:27 +0000 (17:22 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 12 Dec 2019 16:23:12 +0000 (17:23 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/poco_vendor/Manifest [new file with mode: 0644]
dev-ros/poco_vendor/metadata.xml [new file with mode: 0644]
dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild [new file with mode: 0644]
dev-ros/poco_vendor/poco_vendor-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/poco_vendor/Manifest b/dev-ros/poco_vendor/Manifest
new file mode 100644 (file)
index 0000000..3bbccfd
--- /dev/null
@@ -0,0 +1 @@
+DIST poco_vendor-1.2.0.tar.gz 3145 BLAKE2B 6143f73ec9f741ff72147ac43d4876cb17553d8a4ba33d54b60f546cd2988389de4cbc1b3fcb0300f507f91610ba64284515a3d736417f611c3ffa6eb32d5aba SHA512 f38f00028ad1b6b236305761f53748597f1203e267488ba2a08b8c06ad155338a2c413b3e5e5501becdb09aec4600ae700d95765a5b4d0861b163e4f2a9ee413
diff --git a/dev-ros/poco_vendor/metadata.xml b/dev-ros/poco_vendor/metadata.xml
new file mode 100644 (file)
index 0000000..c3d00f2
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>ros@gentoo.org</email>
+               <name>Gentoo ROS Project</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">ros2/poco_vendor</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild b/dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild
new file mode 100644 (file)
index 0000000..ed5cfd5
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-r1
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/ros2/poco_vendor"
+       SRC_URI=""
+else
+       SRC_URI="https://github.com/ros2/poco_vendor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="CMake shim over the poco library"
+HOMEPAGE="https://github.com/ros2/poco_vendor"
+
+LICENSE="Apache-2.0 Boost-1.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       KEYWORDS=""
+else
+       KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+       dev-libs/poco
+"
+RDEPEND="${DEPEND}"
+BDEPEND="ros-meta/ament_cmake[${PYTHON_USEDEP}]
+       ${PYTHON_DEPS}
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+       # This is a build tool that does not install python-related files
+       # ... but we need to propagate the deps and use python3 to build it.
+       local pyimpl="${PYTHON_COMPAT[0]}"
+       python_export "${pyimpl}" EPYTHON PYTHON
+       python_wrapper_setup
+       cmake-utils_src_configure
+}
diff --git a/dev-ros/poco_vendor/poco_vendor-9999.ebuild b/dev-ros/poco_vendor/poco_vendor-9999.ebuild
new file mode 100644 (file)
index 0000000..ed5cfd5
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-r1
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/ros2/poco_vendor"
+       SRC_URI=""
+else
+       SRC_URI="https://github.com/ros2/poco_vendor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="CMake shim over the poco library"
+HOMEPAGE="https://github.com/ros2/poco_vendor"
+
+LICENSE="Apache-2.0 Boost-1.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       KEYWORDS=""
+else
+       KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+       dev-libs/poco
+"
+RDEPEND="${DEPEND}"
+BDEPEND="ros-meta/ament_cmake[${PYTHON_USEDEP}]
+       ${PYTHON_DEPS}
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+       # This is a build tool that does not install python-related files
+       # ... but we need to propagate the deps and use python3 to build it.
+       local pyimpl="${PYTHON_COMPAT[0]}"
+       python_export "${pyimpl}" EPYTHON PYTHON
+       python_wrapper_setup
+       cmake-utils_src_configure
+}