xfce-extra/xfce4-pulseaudio-plugin: bump to 0.4.0
authorJason Zaman <perfinion@gentoo.org>
Tue, 20 Mar 2018 09:46:54 +0000 (17:46 +0800)
committerJason Zaman <perfinion@gentoo.org>
Tue, 20 Mar 2018 09:47:22 +0000 (17:47 +0800)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

xfce-extra/xfce4-pulseaudio-plugin/Manifest
xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.0.ebuild [new file with mode: 0644]

index 08fe815582f1709e035629170cd7fc574d153a49..f7426c0ffd5b96da8d25b48ab154637b4b2fcb10 100644 (file)
@@ -1,2 +1,3 @@
 DIST xfce4-pulseaudio-plugin-0.3.4.tar.bz2 400380 BLAKE2B b8cd4df84f3119d90a7671d8217eaeb83025206d9bfdc5aaae2281cd7c9b13ab03fa8a99ff1eb352f2fa01e889bcd3a505b558ce9884c46b1136bc75a6fb22e7 SHA512 2dfa6a4567caeb2f336b1d9e32cedb5f03e363253549810e768bb51746cd1db362ebd0990098e461a71b8206d81ff877291860a3568a288fe2010498ad486c78
 DIST xfce4-pulseaudio-plugin-0.3.5.tar.bz2 390084 BLAKE2B a43ac67d83cfa113a3429c2fd0e2de1879f9fb9856e136606140ce08d0e70b44ec2cd17a588240edab5609ff8735ee05f7da2314f925205c4aff1b8f574eb767 SHA512 6cfef82b7ca0b2301638c2756f71f7ac03d83c92f3dc40fd24896d1e7879dbab2bd828a66dab1c659a5d93dc63bf505d9ef75094c2588cafd85ba66d202434a5
+DIST xfce4-pulseaudio-plugin-0.4.0.tar.bz2 391068 BLAKE2B c06b05fbb910e7a1d13fde976f6b8b3f0d22de43223bdc8472440c52868cf1f3f37359a81c96efb2644ba202382cb53c2780214d3fe1af7977ec2e9d2f5e8c19 SHA512 28e2185ffea3f6e3e7d07e0cdd5062d423dddb2f7ee4a1e2f2965d4bf65e11cd0a409403ffb7d6afd89206dc37cf5700430ad6a53967395e3a58dde6dd13503f
diff --git a/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.0.ebuild b/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.0.ebuild
new file mode 100644 (file)
index 0000000..4dcbd98
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A panel plug-in for PulseAudio volume control"
+HOMEPAGE="https://git.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug keybinder libnotify wnck"
+
+RDEPEND=">=dev-libs/glib-2.42.0:=
+       media-sound/pulseaudio:=
+       >=x11-libs/gtk+-3.20.0:3=
+       >=xfce-base/libxfce4ui-4.11.0:=[gtk3(+)]
+       >=xfce-base/libxfce4util-4.9.0:=
+       >=xfce-base/xfce4-panel-4.11.0:=
+       >=xfce-base/xfconf-4.6.0:=
+       keybinder? ( dev-libs/keybinder:3= )
+       libnotify? ( x11-libs/libnotify:= )
+       wnck? ( x11-libs/libwnck:3= )"
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       virtual/pkgconfig"
+
+src_configure() {
+       local myconf=(
+               $(use_enable keybinder)
+               $(use_enable libnotify)
+               $(use_enable wnck)
+       )
+
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+
+       if ! has_version media-sound/pavucontrol; then
+               elog "For the 'audio mixer...' shortcut to work, you need to install"
+               elog "an external mixer application. Please either install:"
+               elog
+               elog "  media-sound/pavucontrol"
+               elog
+               elog "or specify another application to use in the 'Properties' dialog."
+       fi
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}