sys-apps/systemd: Allow tests to access kdbus
authorMike Gilbert <floppym@gentoo.org>
Sun, 13 Sep 2015 17:32:17 +0000 (13:32 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sun, 13 Sep 2015 17:33:04 +0000 (13:33 -0400)
Package-Manager: portage-2.2.20

sys-apps/systemd/systemd-226.ebuild
sys-apps/systemd/systemd-9999.ebuild

index f84a4d74ed6f5fd1daa4d3aaec88e5a25ce5acee..6068bc69709411ab16b280f090da113e096d7a06 100644 (file)
@@ -259,6 +259,10 @@ multilib_src_compile() {
 multilib_src_test() {
        multilib_is_native_abi || continue
 
+       # Needed for bus-related tests
+       local -x SANDBOX_WRITE=${SANDBOX_WRITE}
+       addwrite /sys/fs/kdbus
+
        default
 }
 
index f84a4d74ed6f5fd1daa4d3aaec88e5a25ce5acee..6068bc69709411ab16b280f090da113e096d7a06 100644 (file)
@@ -259,6 +259,10 @@ multilib_src_compile() {
 multilib_src_test() {
        multilib_is_native_abi || continue
 
+       # Needed for bus-related tests
+       local -x SANDBOX_WRITE=${SANDBOX_WRITE}
+       addwrite /sys/fs/kdbus
+
        default
 }