sys-kernel/vanilla-kernel: Bump to 5.4.13
authorMichał Górny <mgorny@gentoo.org>
Sat, 18 Jan 2020 04:38:58 +0000 (05:38 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 18 Jan 2020 14:35:56 +0000 (15:35 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-kernel/vanilla-kernel/Manifest
sys-kernel/vanilla-kernel/vanilla-kernel-5.4.13.ebuild [new file with mode: 0644]

index e8116c6d32d277b792a94c3d39437195c6cac6bc..a226861321b93c4e2d36fda39751e601173ead4e 100644 (file)
@@ -6,6 +6,7 @@ DIST linux-4.19.96.tar.xz 103395480 BLAKE2B 1bc24dd40d427e088e1569be4d5964ae9202
 DIST linux-5.4.10.tar.xz 109453652 BLAKE2B 88706cfc05ec1cc201f08e069dc6ad4f8e6fb49dbef5937208ba1e752e18b46639a5d32d4d0e270a0f2f6ed872aed70beeb2b0367d41fe443437331902a90bb2 SHA512 6328ad7e18b6fa982415b0de75e3384f58ce8428bd8c212871a31f3885a0819d241138d384b2e6d1b74a1d260229a027f9c1674a65f5b6c48e6b25e3024a0974
 DIST linux-5.4.11.tar.xz 109456460 BLAKE2B 38f2620f7773ddd1d26e0638f1e2200e5f37611dc1d606a4200e352a4593bd934f109ee936093194347a26f8797683bbed5e9b81fab353d23bbe1bf28fda2ddc SHA512 75aba0e124def6604cc0050ca7b005d1d5398498d71199cb9e196d5739f0fc25664637849025aa7f965d46f9aecb2fafadc7b35dcb83e396dc4d3a084c458497
 DIST linux-5.4.12.tar.xz 109451372 BLAKE2B f08d30011b2021724a240f45a4d0a92ba01b97d0d2d33ce0d88aeb6dfb0a2e5a532fd55ad0a2ef0e3ec160cb23b351a09b494382e80b0db85bcfe7cfeaa554dd SHA512 d178d775b5d6204b2f53c38ecf81d52141a5520b63e758992c75a59d983e448db2a0c220a17b62588baaad1eda2d9b4a6a86e757f5d50041170559ef6bbc2da0
+DIST linux-5.4.13.tar.xz 109463864 BLAKE2B d610a2bf375c9147b26d6e314c1e86b9f32453572c1e8a859be3ac5fa42d7ba647334ef76a92a7e1e61f78fa256692bec3d62003589017840a37947d9d5b1de0 SHA512 e7aaa541ccf66ca8373fe53794786c8b819da824b17acc497d5080f4fff5bef90bab1da531fa8f62a013f40472f5c1dfafb4bd4f42ecc1bf851042d22e72c4a7
 DIST linux-5.4.3-arch1.i686.config 241295 BLAKE2B 795b6286bd1e7dc6aa5c1428e7bf08c204ce6c8cbee57863e9f64f8990790cc4398a7d062b54c89b1b80640f02a40fce028d9397725db0f968e8028b0611a20f SHA512 8c7387ded21c02b9cffee0e6d61a7040c44deae21764f743f7719f0d1c7adf684f6b62a501fe31709787ba741859e55fc3b8a3d3d27e52c09f2d8604212bf0a7
 DIST linux-5.4.7-arch1.i686.config 241295 BLAKE2B da45f2de600fafdb48e9bb37e6f7a8ea57ed31dc6fb47062bcee694db0b824844c0556ad6a88afa33bf3a365f50c9ac6326389cfa87d0e47a012252fa1444536 SHA512 dcfd9c03cbafeeb942fd37c1f18432aeeacaff438cb88528e17aa8c28bae20090695a2acad08a707e66ecaa5851aa47b012baa6d9274c617fa8c71cde641e8ec
 DIST linux-5.4.7.arch1-1.amd64.config 241598 BLAKE2B 536cce5cc23cf20e71cba7468a125557f85d8ffc3cb194dced79bd489d39f2e4ed3960816d15d1491007d11b3af466e0a74267f983dfcc5f511f9f566f7e9821 SHA512 8658db603e180c75caf76972d85ecf8a4e9c9cf6e047b4f9fc7cba0fa426f434361528c1c29b5580f116cdd23091bf9afb6635d751f3b90c4e968d16db90eac1
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.13.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.13.ebuild
new file mode 100644 (file)
index 0000000..dcf1bf9
--- /dev/null
@@ -0,0 +1,73 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-build
+
+MY_P=linux-${PV}
+# https://git.archlinux.org/svntogit/packages.git/log/trunk/config?h=packages/linux
+AMD64_CONFIG_VER=5.4.7.arch1-1
+AMD64_CONFIG_HASH=ff79453bc0451a9083bdaa02c3901372d61a9982
+# https://git.archlinux32.org/packages/log/core/linux/config.i686
+I686_CONFIG_VER=5.4.7-arch1
+I686_CONFIG_HASH=f888688da499e17f3c7a5f15a3c44482a29acc2c
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+       amd64? (
+               https://git.archlinux.org/svntogit/packages.git/plain/trunk/config?h=packages/linux&id=${AMD64_CONFIG_HASH}
+                       -> linux-${AMD64_CONFIG_VER}.amd64.config
+       )
+       x86? (
+               https://git.archlinux32.org/packages/plain/core/linux/config.i686?id=${I686_CONFIG_HASH}
+                       -> linux-${I686_CONFIG_VER}.i686.config
+       )"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       !sys-kernel/vanilla-kernel-bin:${SLOT}"
+
+pkg_pretend() {
+       mount-boot_pkg_pretend
+
+       ewarn "This is an experimental package.  The built kernel and/or initramfs"
+       ewarn "may not work at all or fail with your bootloader configuration.  Please"
+       ewarn "make sure to keep a backup kernel available before testing it."
+}
+
+src_prepare() {
+       default
+
+       # prepare the default config
+       case ${ARCH} in
+               amd64)
+                       cp "${DISTDIR}"/linux-${AMD64_CONFIG_VER}.amd64.config .config || die
+                       ;;
+               x86)
+                       cp "${DISTDIR}"/linux-${I686_CONFIG_VER}.i686.config .config || die
+                       ;;
+               *)
+                       die "Unsupported arch ${ARCH}"
+                       ;;
+       esac
+
+       local config_tweaks=(
+               # shove arch under the carpet!
+               -e 's:^CONFIG_DEFAULT_HOSTNAME=:&"gentoo":'
+               # we do support x32
+               -e '/CONFIG_X86_X32/s:.*:CONFIG_X86_X32=y:'
+               # disable signatures
+               -e '/CONFIG_MODULE_SIG/d'
+               -e '/CONFIG_SECURITY_LOCKDOWN/d'
+               # disable compression to allow stripping
+               -e '/CONFIG_MODULE_COMPRESS/d'
+               # disable gcc plugins to unbreak distcc
+               -e '/CONFIG_GCC_PLUGIN_STRUCTLEAK/d'
+       )
+       sed -i "${config_tweaks[@]}" .config || die
+}