dev-libs/spdlog: Cleanup old version
authorCraig Andrews <candrews@gentoo.org>
Thu, 19 Mar 2020 20:24:36 +0000 (16:24 -0400)
committerCraig Andrews <candrews@gentoo.org>
Thu, 19 Mar 2020 20:24:55 +0000 (16:24 -0400)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-libs/spdlog/Manifest
dev-libs/spdlog/spdlog-1.3.1.ebuild [deleted file]

index ce93e6094e9c79ef3b26b298569e45574f73bf22..db82b5117eab2046a2aeba19e937080bf18a8262 100644 (file)
@@ -1,2 +1 @@
-DIST spdlog-1.3.1.tar.gz 202634 BLAKE2B 2465a8d1a38af1527ae66d92f5dd91ad504d01e44ac47702e315f7448e19f01743627357132f0561e48807315df9b102f337f95cab5a7aae3ec0ae7ceff940b9 SHA512 a851a44b6384f493dd312ae0a611d068af46bbfe8daf1c2f61f13d8836a3801f41b339074fbe8da8e428131c82fa5c4a9e3320a55cbdd4b7aff8bb349dfff7dd
 DIST spdlog-1.5.0.tar.gz 270416 BLAKE2B bac6c6650f8347458dd2dd66f318b43a769b0896d68f6a6f1310754527a69feaa52b2f6f48d67c7e811c2dafa5d3863a9a07c738df8c12abed2718fb06254b28 SHA512 78991c943dd95af563c4b29545b9b5d635caf1af5031262dde734ecf70c0b4ae866d954ee77b050f9f0cc089a3bc57ee9583895e51cb00dd1cc6c10ff905ca34
diff --git a/dev-libs/spdlog/spdlog-1.3.1.ebuild b/dev-libs/spdlog/spdlog-1.3.1.ebuild
deleted file mode 100644 (file)
index 69ab5a2..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Very fast, header only, C++ logging library"
-HOMEPAGE="https://github.com/gabime/spdlog"
-
-if [[ ${PV} == *9999 ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="https://github.com/gabime/spdlog"
-else
-       SRC_URI="https://github.com/gabime/spdlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="amd64"
-fi
-
-LICENSE="MIT"
-SLOT="0/1"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-libs/libfmt:0/5
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-1.0.0-unbundle-fmt.patch" )
-
-src_configure() {
-       rm -r include/spdlog/fmt/bundled || die
-
-       local mycmakeargs=(
-               -DSPDLOG_BUILD_EXAMPLES=no
-               -DSPDLOG_BUILD_BENCH=no
-               -DSPDLOG_BUILD_TESTS=$(usex test)
-       )
-
-       cmake_src_configure
-}