dev-util/include-what-you-use: bump up to 9.0
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 26 Oct 2019 12:25:24 +0000 (13:25 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 26 Oct 2019 12:26:22 +0000 (13:26 +0100)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-util/include-what-you-use/Manifest
dev-util/include-what-you-use/include-what-you-use-9.0.ebuild [new file with mode: 0644]

index d564cfd0573104020eac3ffa918b19f0227456fb..21fd7312d226c0dd8ab36520fc7c06ab31d3fd78 100644 (file)
@@ -1,3 +1,4 @@
 DIST include-what-you-use-6.0.src.tar.gz 440406 BLAKE2B 485a61dd4f72c158ad9c798c8121d7af9134d79b94c9c30c14674a62007e9fc05acc7e2341cc3282288611beb9138768bf11cd2d73efed372adab83e90b268db SHA512 2bf2593dba252d870074125f976a237e901e969323969f2c8fb030e8376bb230f1d5c2baecc8cd8fad7099e83589c7666c44cd178d2094f6e883cace1e53ad90
 DIST include-what-you-use-7.0.src.tar.gz 541840 BLAKE2B bf20a5598f02f03e5f714582653b8062eab6e414967ef2374c28bb6c1cdce8f73f80e3b2f4953fd943587ce17dc657cf6ab2a9db4208a59030d432f6a40532e5 SHA512 50d186b2e09c3595cc2dc7513e5db74da0038987158c2c45ef4279c67c50de621ca6499b07894ee203f25566aafaddde4b05840946f921678499d2efc131575a
 DIST include-what-you-use-8.0.src.tar.gz 545788 BLAKE2B 7b70d951b7ab2d62a8a6168ebf86dc76fd406159155dd93a509b8c39953506166ac18da3028be8dc7edfbb39eb96613b0e344067154dd8614fe7c63ad3ef04c6 SHA512 e75e91ce198b1ec446ed34afcf9fdbcb0534c5edc5346e4884f0f589c73512d778c428aa71c1b109d45a45543a952438610ab21e32ef1f03ff1a014823ed8425
+DIST include-what-you-use-9.0.src.tar.gz 589377 BLAKE2B b695354787070948d81e3e80b07bbe47a84b5609262df2220b6a62e6d648865b17e060951819f45956c6ca858977614d6e0401640509599b391a1165521b20de SHA512 f2d6ba05121a9968da9e42e8ac66f83ca0f35bfbe7cb1d616e2c6479cf2833c4668cb86e46a04ffcd5e77f10a575da9eeee5272c7609b5afad555d79cb640fb4
diff --git a/dev-util/include-what-you-use/include-what-you-use-9.0.ebuild b/dev-util/include-what-you-use/include-what-you-use-9.0.ebuild
new file mode 100644 (file)
index 0000000..2b95d90
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit cmake-utils flag-o-matic llvm python-single-r1
+
+DESCRIPTION="Find unused include directives in C/C++ programs"
+HOMEPAGE="https://include-what-you-use.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/clang_${PV}.tar.gz -> ${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+LLVM_MAX_SLOT=9
+
+RDEPEND="sys-devel/llvm:${LLVM_MAX_SLOT}
+       sys-devel/clang:${LLVM_MAX_SLOT}
+       ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${PN}-clang_${PV}
+
+pkg_setup() {
+       llvm_pkg_setup
+       python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       cmake-utils_src_prepare
+       python_fix_shebang .
+}
+
+src_configure() {
+       local mycmakeargs=(
+               # Note [llvm install path]
+               # Unfortunately all binaries using clang driver
+               # have to reside at the same path depth as
+               # 'clang' binary itself. See bug #625972
+               # Thus as a hack we install it to the same directory
+               # as llvm/clang itself.
+               -DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
+       )
+       cmake-utils_src_configure
+}
+
+src_test() {
+       "${EPYTHON}" run_iwyu_tests.py
+}