app-editors/neovim: version bump to 0.3.7
authorTim Harder <radhermit@gentoo.org>
Thu, 13 Jun 2019 02:20:23 +0000 (21:20 -0500)
committerTim Harder <radhermit@gentoo.org>
Thu, 13 Jun 2019 02:24:02 +0000 (21:24 -0500)
Closes: https://bugs.gentoo.org/686400
Closes: https://bugs.gentoo.org/685162

Signed-off-by: Tim Harder <radhermit@gentoo.org>
app-editors/neovim/Manifest
app-editors/neovim/neovim-0.3.7.ebuild [new file with mode: 0644]

index cca95156a72cab418477a3f758dac02dce498913..a9b19d6c0d578bccd198ab8508892c6d41aa0ea1 100644 (file)
@@ -2,3 +2,4 @@ DIST neovim-0.3.1.tar.gz 8937900 BLAKE2B 05de31d194a69b9cecd34210ecfe7460968f425
 DIST neovim-0.3.2.tar.gz 9230960 BLAKE2B c9d0ee2f679f411c3ece2aa186e31d0143479f6ec19d4d54c34cd4be519a92e9f213fc821b347a0e3af6817b6ce745cdff523af41d5b558940b76d9df726253b SHA512 1192d9330da3ab543dcb39bdff517637c7a52be558ad07a60de27bbf051432064edc230b46ddd9cdcae006ba1340550128e4d4ced7105f1aab57b13c2c4479ae
 DIST neovim-0.3.3.tar.gz 9231632 BLAKE2B 96bffabcc7c7c2edca79f64e51348954b550910d71c55d00dd3d91d9c51a75742e5a4b919701c24c00de1d372a4269b491028e61afcce45375360dc35f3b943e SHA512 2e2910e0dafdff69d2d9f54376c6d7c64e0f172bda02f85281fe6e694e7d81365e682793e454a0ca6f6c1b8a4ed9120bbfe574afa1fd0e6368e06af743d7d147
 DIST neovim-0.3.4.tar.gz 9231575 BLAKE2B 92e727264442794ae27642451c90381262f9882e26d9865a2ff6c1bc4060b070ab49cd11194c3a88dafecda5bc1909963b2cc8b382198dc7c117ba056b7a4ebe SHA512 fbf22ccffbb36c082bfe9a66b3d0180a78581102732a44ab7a5417aef517c88b69406491854613a1cf347ddab6fc6e277f959887556d2c0068cf181e4d88c36b
+DIST neovim-0.3.7.tar.gz 9231661 BLAKE2B 6eade77f8654bc95170f4c052c5700a6ad42aff920889bf4036e6ff931cdeeabb908aeedb44e68efca3500beb797cf2361e09d85456a2c17431e005a64bafff4 SHA512 1d770a4643a44da65f0a03c90e18e89f337b16ec3eca20dbffa21bcab10c836062ef82974437b64bd766f7b07317cd3dc8e3e72b9d5d0911b1d4f2c528cd20c2
diff --git a/app-editors/neovim/neovim-0.3.7.ebuild b/app-editors/neovim/neovim-0.3.7.ebuild
new file mode 100644 (file)
index 0000000..c3e917a
--- /dev/null
@@ -0,0 +1,96 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="Vim-fork focused on extensibility and agility."
+HOMEPAGE="https://neovim.io"
+
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/neovim/neovim.git"
+else
+       SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="Apache-2.0 vim"
+SLOT="0"
+IUSE="+clipboard +luajit +nvimpager python remote ruby +tui +jemalloc"
+
+CDEPEND="
+       dev-libs/libuv:0=
+       dev-libs/msgpack:0=
+       luajit? ( dev-lang/luajit:2 )
+       !luajit? (
+               dev-lang/lua:=
+               dev-lua/LuaBitOp
+       )
+       tui? (
+               dev-libs/libtermkey
+               >=dev-libs/unibilium-2.0.0:0=
+       )
+       dev-libs/libvterm
+       dev-lua/lpeg[luajit=]
+       dev-lua/mpack[luajit=]
+       jemalloc? ( dev-libs/jemalloc )
+       net-libs/libnsl"
+
+DEPEND="
+       ${CDEPEND}
+       dev-util/gperf
+       virtual/libintl
+       virtual/libiconv
+       app-eselect/eselect-vi"
+
+RDEPEND="
+       ${CDEPEND}
+       python? ( dev-python/neovim-python-client )
+       ruby? ( dev-ruby/neovim-ruby-client )
+       remote? ( dev-python/neovim-remote )
+       clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"
+
+CMAKE_BUILD_TYPE=Release
+
+src_prepare() {
+       # use our system vim dir
+       sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
+               -i src/nvim/globals.h || die
+
+       # add eclass to bash filetypes
+       sed -e 's|*.ebuild|*.ebuild,*.eclass|' -i runtime/filetype.vim || die
+
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DFEAT_TUI=$(usex tui)
+               -DENABLE_JEMALLOC=$(usex jemalloc)
+               -DPREFER_LUA=$(usex luajit no yes)
+       )
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+
+       # install a default configuration file
+       insinto /etc/vim
+       doins "${FILESDIR}"/sysinit.vim
+
+       # conditionally install a symlink for nvimpager
+       if use nvimpager; then
+               dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
+       fi
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+}