media-gfx/photivo: fix location of header file in live ebuild
authorIan Delaney <idella4@gentoo.org>
Mon, 21 Sep 2015 04:58:31 +0000 (12:58 +0800)
committerIan Delaney <idella4@gentoo.org>
Mon, 21 Sep 2015 04:59:25 +0000 (12:59 +0800)
patch by wraeth submitted via, and closes, bug #560120

Package-Manager: portage-2.2.20.1

media-gfx/photivo/photivo-9999.ebuild

index 9f921e5abd84d333c1d025641a2b46ca6fb338f8..b6626ed829ae4b0012a35bdfb6401c3ecc893769 100644 (file)
@@ -8,7 +8,7 @@ inherit qt4-r2 mercurial
 
 DESCRIPTION="Photo processor for RAW and Bitmap images"
 HOMEPAGE="http://www.photivo.org"
-EHG_REPO_URI="https://photivo.googlecode.com/hg/"
+EHG_REPO_URI="https://bitbucket.org/Photivo/photivo"
 
 LICENSE="GPL-3"
 SLOT="0"
@@ -33,10 +33,18 @@ src_prepare() {
        local File
        for File in $(find "${S}" -type f); do
                if grep -sq ccache ${File}; then
-                       sed -e 's/ccache//' -i "${File}"
+                       sed -e 's/ccache//' -i "${File}" || die
                fi
        done
 
+       # bug 560120 - fix includes for lensfun.h
+       sed -s -e 's:lensfun.h:lensfun\/lensfun.h:' \
+               -i ReferenceMaterial/LensFunSample.c \
+               -i Sources/ptConstants.h \
+               -i Sources/ptImage.h \
+               -i Sources/ptImage_Lensfun.cpp \
+               -i Sources/ptLensfun.h || die
+
        # useless check (no pkgconfig file is provided)
        sed -e "/PKGCONFIG += CImg/d" \
                -i photivoProject/photivoProject.pro || die