Version bump
authorTristan Heaven <tristan@gentoo.org>
Thu, 4 Jan 2007 17:34:06 +0000 (17:34 +0000)
committerTristan Heaven <tristan@gentoo.org>
Thu, 4 Jan 2007 17:34:06 +0000 (17:34 +0000)
Package-Manager: portage-2.1.2_rc4-r5

games-arcade/smclone/ChangeLog
games-arcade/smclone/files/digest-smclone-0.99.4 [new file with mode: 0644]
games-arcade/smclone/files/smclone-0.99.4-leveldir.patch [new file with mode: 0644]
games-arcade/smclone/smclone-0.99.4.ebuild [new file with mode: 0644]

index 686318effd0d09c2f24a6d5f4ef861c9f7c2ca30..a9fd0954f1cc3452ac4e9e4dd050a2029a3a3381 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for games-arcade/smclone
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/smclone/ChangeLog,v 1.13 2006/11/27 23:42:09 nyhm Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/smclone/ChangeLog,v 1.14 2007/01/04 17:34:06 nyhm Exp $
+
+*smclone-0.99.4 (04 Jan 2007)
+
+  04 Jan 2007; Tristan Heaven <nyhm@gentoo.org>
+  -files/smclone-0.99.3-build.patch, -files/smclone-0.99.3-paths.patch,
+  +files/smclone-0.99.4-leveldir.patch, -smclone-0.99.3.ebuild,
+  +smclone-0.99.4.ebuild:
+  Version bump
 
   27 Nov 2006; Tristan Heaven <nyhm@gentoo.org> smclone-0.99.3.ebuild:
   Install all of the xsd files used by xerces-c
diff --git a/games-arcade/smclone/files/digest-smclone-0.99.4 b/games-arcade/smclone/files/digest-smclone-0.99.4
new file mode 100644 (file)
index 0000000..48e90d5
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 e991c78a6f17c23f43541abf244979ee SMC_0.99.4_game.zip 12416225
+RMD160 30884335d0672930a1d05f28e9e4593ed3822e72 SMC_0.99.4_game.zip 12416225
+SHA256 1c64f70360a81f8d1444b7d05d375277ce907e98cd5f175237f4cfb908fbd7f9 SMC_0.99.4_game.zip 12416225
+MD5 710261e92e44066a811a8bbf68dba526 music_3.1_high.zip 28684034
+RMD160 728e2c029f47147d31894caa1b7722daf4635386 music_3.1_high.zip 28684034
+SHA256 8497dce0547d638daf05e0277c7b3fc5dfe33948ddb538b4bb4fba95acccc823 music_3.1_high.zip 28684034
diff --git a/games-arcade/smclone/files/smclone-0.99.4-leveldir.patch b/games-arcade/smclone/files/smclone-0.99.4-leveldir.patch
new file mode 100644 (file)
index 0000000..fcb46e8
--- /dev/null
@@ -0,0 +1,11 @@
+--- src/user/preferences.cpp
++++ src/user/preferences.cpp
+@@ -435,7 +435,7 @@
+               if( val.length() > 2 )\r
+               {\r
+                       // todo : check if the directory exists\r
+-                      level_dir = val;\r
++                      level_dir = LEVEL_DIR;\r
+               }\r
+       }\r
+ }\r
diff --git a/games-arcade/smclone/smclone-0.99.4.ebuild b/games-arcade/smclone/smclone-0.99.4.ebuild
new file mode 100644 (file)
index 0000000..2565536
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/smclone/smclone-0.99.4.ebuild,v 1.1 2007/01/04 17:34:06 nyhm Exp $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+inherit autotools eutils games
+
+MUSIC_V=3.1
+DESCRIPTION="Secret Maryo Chronicles"
+HOMEPAGE="http://www.secretmaryo.org/"
+SRC_URI="mirror://sourceforge/${PN}/SMC_${PV}_game.zip
+       mirror://sourceforge/${PN}/music_${MUSIC_V}_high.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-games/cegui-0.5.0
+       virtual/opengl
+       virtual/glu
+       media-libs/libsdl
+       media-libs/sdl-image
+       media-libs/sdl-mixer
+       media-libs/sdl-ttf"
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig
+       app-arch/unzip"
+
+S=${WORKDIR}
+
+pkg_setup() {
+       games_pkg_setup
+       if ! built_with_use media-libs/sdl-image png ; then
+               die "Please emerge sdl-image with USE=png"
+       fi
+       if ! built_with_use dev-games/cegui devil opengl ; then
+               die "Please emerge cegui with USE=\"devil opengl\""
+       fi
+}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}"/${P}-leveldir.patch
+       eautoreconf
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "emake install failed"
+       newicon data/icon/window_32.png ${PN}.png
+       make_desktop_entry smc "Secret Maryo Chronicles"
+       dodoc docs/*.txt
+       dohtml docs/{*.css,*.html}
+       prepgamesdirs
+}