app-admin/salt: remove random_org test
authorPatrick McLean <chutzpah@gentoo.org>
Tue, 29 Sep 2015 01:18:27 +0000 (18:18 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Tue, 29 Sep 2015 01:18:27 +0000 (18:18 -0700)
This fixes bug #560374, the random_org test does network traffic, which
breaks with FEATURES=network-sandbox.

Reported-by: Thomas D. <whissi@whissi.de>
app-admin/salt/salt-2015.8.0.ebuild

index e8568efce203f628243170791af6fa2260749bfd..aaf7c84a1f5c9021cf0c97be458e4709d54f2d89 100644 (file)
@@ -89,7 +89,8 @@ PATCHES=(
 
 python_prepare() {
        # this test fails because it trys to "pip install distribute"
-       rm tests/unit/{modules,states}/zcbuildout_test.py tests/unit/modules/{rh_ip,win_network}_test.py
+       rm tests/unit/{modules,states}/zcbuildout_test.py \
+               tests/unit/modules/{rh_ip,win_network,random_org}_test.py
 }
 
 python_install_all() {