app-misc/birthday: Fix test failures
authorJustin Lecher <jlec@gentoo.org>
Fri, 25 Dec 2015 12:03:22 +0000 (13:03 +0100)
committerJustin Lecher <jlec@gentoo.org>
Fri, 25 Dec 2015 12:08:04 +0000 (13:08 +0100)
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=568930

Package-Manager: portage-2.2.26
Signed-off-by: Justin Lecher <jlec@gentoo.org>
app-misc/birthday/birthday-1.6.2.ebuild

index 600b93523b1ba41ab35c9357ce70e3b3b119cdc6..c8f79f8f04dab249a4d9e94a9b1dea02571b2b11 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -18,8 +18,12 @@ src_unpack() {
        cd "${S}"
 
        # Don't strip, install in correct share dir and respect CFLAGS
-       sed -i -e "s:install -s:install:g" -e "s:#SHARE:SHARE:g" -e "s:-O2:${CFLAGS}:g" \
-               Makefile || die
+       sed \
+               -e "s:install -s:install:g" -e "s:#SHARE:SHARE:g" -e "s:-O2:${CFLAGS}:g" \
+               -i Makefile || die
+       sed \
+               -e 's:grep -v:grep --binary-files=text -v:g' \
+               -i runtest.sh || die
 }
 
 src_compile() {