net-libs/ldns: reorder linking sources
authorMarc Schiffbauer <mschiff@gentoo.org>
Sun, 29 Sep 2019 13:43:42 +0000 (15:43 +0200)
committerMarc Schiffbauer <mschiff@gentoo.org>
Sun, 29 Sep 2019 13:49:49 +0000 (15:49 +0200)
fixes #641598

Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
net-libs/ldns/files/ldns-1.7.1-Makefile.patch [new file with mode: 0644]
net-libs/ldns/ldns-1.7.1-r1.ebuild

diff --git a/net-libs/ldns/files/ldns-1.7.1-Makefile.patch b/net-libs/ldns/files/ldns-1.7.1-Makefile.patch
new file mode 100644 (file)
index 0000000..d654bbd
--- /dev/null
@@ -0,0 +1,11 @@
+--- Makefile.in.orig   2019-09-29 15:17:24.728446345 +0200
++++ Makefile.in        2019-09-29 15:18:09.544008785 +0200
+@@ -301,7 +301,7 @@
+       $(COMP_LIB) -I./include/ldns $(LIBSSL_CPPFLAGS) $(PYTHON_CPPFLAGS) $(PYTHON_X_CFLAGS) -c $(pywrapdir)/ldns_wrapper.c -o $@
+ _ldns.la: ldns_wrapper.lo libldns.la 
+-      $(LIBTOOL) --tag=CC --mode=link $(CC) $(CFLAGS) $(PYTHON_CFLAGS) $(LDFLAGS) $(PYTHON_LDFLAGS) -module -version-info $(version_info) -no-undefined -o $@ ldns_wrapper.lo -rpath $(python_site) -L. -L.libs -lldns $(LIBS)
++      $(LIBTOOL) --tag=CC --mode=link $(CC) $(CFLAGS) $(PYTHON_CFLAGS) -module -version-info $(version_info) -no-undefined -o $@ ldns_wrapper.lo -rpath $(python_site) -L. -L.libs -lldns $(LDFLAGS) $(PYTHON_LDFLAGS) $(LIBS) 
+ $(p5_dns_ldns_dir)/Makefile: $(p5_dns_ldns_dir)/Makefile.PL
+       BUILDDIR=`pwd`; cd $(p5_dns_ldns_dir); LD_LIBRARY_PATH="$$BUILDDIR/.libs:$$LD_LIBRARY_PATH" DYLD_LIBRARY_PATH="$$BUILDDIR/.libs:$$DYLD_LIBRARY_PATH" $(PERL) Makefile.PL LIBS="-L$$BUILDDIR/.libs -lldns" INC="-I$$BUILDDIR"
index c01ece3861569f151313c1bbbd81b5ad475aefc9..071708308e488765822468840fbcf1e4d7179ad6 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python2_7 python3_5 )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
 inherit eutils multilib-minimal python-single-r1
 
 DESCRIPTION="a library with the aim to simplify DNS programming in C"
@@ -74,8 +74,7 @@ multilib_src_configure() {
 
 src_prepare() {
        default
-       #epatch "${FILESDIR}/${P}-CVE-2017-1000231.patch"
-       #epatch "${FILESDIR}/${P}-CVE-2017-1000232.patch"
+       epatch "${FILESDIR}/${P}-Makefile.patch"
        # remove non-existing dependency for target packaging/libldns.pc
        sed -i 's,packaging/libldns.pc.in,,' "${S}"/Makefile.in || die 'could not patch Makefile.in'
 }