net-misc/lldpd-1.0.5-r1: Add patch to not call cpp in header test
authorPatrick McLean <patrick.mclean@sony.com>
Fri, 29 May 2020 20:39:07 +0000 (13:39 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Fri, 29 May 2020 20:39:35 +0000 (13:39 -0700)
Closes: https://bugs.gentoo.org/725234
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
net-misc/lldpd/files/lldpd-1.0.5-cpp.patch [new file with mode: 0644]
net-misc/lldpd/lldpd-1.0.5-r1.ebuild

diff --git a/net-misc/lldpd/files/lldpd-1.0.5-cpp.patch b/net-misc/lldpd/files/lldpd-1.0.5-cpp.patch
new file mode 100644 (file)
index 0000000..0c3fc19
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
+index 0d5f2f3..cc41a8a 100644
+--- a/src/daemon/Makefile.am
++++ b/src/daemon/Makefile.am
+@@ -108,7 +108,7 @@ CLEANFILES    += syscall-names.h
+ syscall-names.h:
+       $(AM_V_GEN)
+       $(AM_V_at)echo "static const char *syscall_names[] = {" > $@ ;\
+-      echo "#include <sys/syscall.h>" | cpp -dM | grep '^#define __NR_' | \
++      echo "#include <sys/syscall.h>" | $(CPP) -dM | grep '^#define __NR_' | \
+               LC_ALL=C sed -r -n -e 's/^\#define[ \t]+__NR_([a-z0-9_]+)[ \t]+([0-9]+)(.*)/ [\2] = "\1",/p' >> $@ ;\
+       echo "};" >> $@
+ nodist_liblldpd_la_SOURCES += syscall-names.h
index bdb15ea083d974fff4b2aee9e81de7ebbcb4fc4d..8a440b4d037b8da6c360be19a706b853e50fad88 100644 (file)
@@ -41,6 +41,7 @@ REQUIRED_USE="graph? ( doc )"
 
 PATCHES=(
        "${FILESDIR}/lldpd-1.0.5-seccomp.patch"
+       "${FILESDIR}/lldpd-1.0.5-cpp.patch"
 )
 
 src_prepare() {