dev-ruby/paramesan: initial import of 0.1.1
authorHans de Graaff <graaff@gentoo.org>
Sat, 16 Sep 2017 06:19:59 +0000 (08:19 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sat, 16 Sep 2017 06:21:13 +0000 (08:21 +0200)
New dependency for dev-ruby/riel

Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-ruby/paramesan/Manifest [new file with mode: 0644]
dev-ruby/paramesan/metadata.xml [new file with mode: 0644]
dev-ruby/paramesan/paramesan-0.1.1.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/paramesan/Manifest b/dev-ruby/paramesan/Manifest
new file mode 100644 (file)
index 0000000..480a2e1
--- /dev/null
@@ -0,0 +1 @@
+DIST paramesan-0.1.1.tgz 4064 SHA256 7ce7b803371660a80218971f7766ed9339dd0597de37ad888ae98380ae5eaf57 SHA512 927595ed9686fb8833beaabf4421cb2c4908bf6e2e1c656034a79c839c292b503ca0ae211f8bdd3916501a281eb2f0b374fc5f4c90615629170e1ba767f0e7fc WHIRLPOOL fc7ef48203852cafb9b2e94884f3cabfbc9520c7b389ec6254ba40e10e6f29653e822e4d4f22ab05a20eed22b433e688ea609b1a330eadc6827ab5b9690480c4
diff --git a/dev-ruby/paramesan/metadata.xml b/dev-ruby/paramesan/metadata.xml
new file mode 100644 (file)
index 0000000..f7b84e9
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>ruby@gentoo.org</email>
+    <name>Gentoo Ruby Project</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="github">jpace/riel</remote-id>
+  </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/paramesan/paramesan-0.1.1.ebuild b/dev-ruby/paramesan/paramesan-0.1.1.ebuild
new file mode 100644 (file)
index 0000000..18a2cb2
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="paramesan.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parameterized tests in Ruby"
+HOMEPAGE="https://github.com/jpace/paramesan"
+
+SRC_URI="https://github.com/jpace/paramesan/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""