media-video/obs-studio: version bump to 23.2.1
authorJimi Huotari <chiitoo@gentoo.org>
Wed, 12 Jun 2019 12:14:34 +0000 (15:14 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 22 Jun 2019 11:44:01 +0000 (13:44 +0200)
Comes with a patch to correct the 'libdir' for
'libobs.pc'.

Upstream PR: https://github.com/obsproject/obs-studio/pull/1932

Bug: https://bugs.gentoo.org/644538
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/12246
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-video/obs-studio/Manifest
media-video/obs-studio/files/obs-studio-23.2.1-use-correct-libdir.patch [new file with mode: 0644]
media-video/obs-studio/obs-studio-23.2.1.ebuild [new file with mode: 0644]

index 2c408bddf18cd3f2bcfde1bc966b852f5ebaaf12..b1a53a3d46e5e595edeb4fb9ff23329f83a628f7 100644 (file)
@@ -1,2 +1,3 @@
 DIST obs-studio-23.0.1.tar.gz 6223214 BLAKE2B c3b65ad9134aefc36a3fa33b8d185a1ee76f76c10edd30d5ad8a7af86605c4e7b3b8d83c5570203d926655131f7c20f4ef11dcbf55c7af745efc2b68d4933c54 SHA512 6877d4bf635a9769d634683a85075a5fe3a5de1fcc83882647dfbc379a897eee05b69c2159e290ff73f53aa7c03027ea4ea15e1169de57c2c50f4e504eff410f
 DIST obs-studio-23.1.0.tar.gz 6192139 BLAKE2B 8c85d21f68b0dc799a8fdfce3ff94d837d0e02bfa55606eec9985d2c2d1c3d9ae78664ba8b17f393abb197f1595fa0f78f314fe474883a81166d9c6a0967682c SHA512 ab4f71430ae314774afbba8b8e39c4eb35ab147d49d6d33b188e7a820b1198ccbb6005fad111502834652b5261b88d07c075094a8303ea7294da3171e8e015bb
+DIST obs-studio-23.2.1.tar.gz 6204515 BLAKE2B bd025a1ec2809e8a0b47fba79c6a3d40feb255a03a461725501a9c7cdbc40c04b75ff714fa4b3787f876a3f524f3371119a3ea9666c3aeb003184f1eb2a63123 SHA512 aabc23d825c2ca3f40274a8e2c4935939dab4955d929c44b28cebde114e808543c1c0dc05791bb6d9f2611effb0f2cb3e20c9a653154c30a9851ea94e74c8169
diff --git a/media-video/obs-studio/files/obs-studio-23.2.1-use-correct-libdir.patch b/media-video/obs-studio/files/obs-studio-23.2.1-use-correct-libdir.patch
new file mode 100644 (file)
index 0000000..619c414
--- /dev/null
@@ -0,0 +1,50 @@
+From ab67b39257be83eaab87c4a938c4c58b5cccad7e Mon Sep 17 00:00:00 2001
+From: Jimi Huotari <chiitoo@gentoo.org>
+Date: Fri, 21 Jun 2019 17:48:32 +0300
+Subject: [PATCH] cmake: Install 'libobs.pc' under the correct 'libdir'
+
+In 'libobs/CMakeLists.txt', use '${CMAKE_INSTALL_LIBDIR}' instead of
+'${CMAKE_INSTALL_PREFIX}/lib', as the latter results into 'libobs.pc'
+being installed under '/lib' when '/lib64' would be more appropriate.
+
+In 'libobs/libobs.pc.in', use '@CMAKE_INSTALL_FULL_LIBDIR@' for
+'libdir', '@CMAKE_INSTALL_FULL_INCLUDEDIR@' for 'includedir',
+and '@CMAKE_INSTALL_PREFIX@' for 'prefix'.
+
+Gentoo-Bug: https://bugs.gentoo.org/644538
+---
+ libobs/CMakeLists.txt | 2 +-
+ libobs/libobs.pc.in   | 6 +++---
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/libobs/CMakeLists.txt b/libobs/CMakeLists.txt
+index fed3e694..86811481 100644
+--- a/libobs/CMakeLists.txt
++++ b/libobs/CMakeLists.txt
+@@ -454,7 +454,7 @@ if(UNIX AND NOT APPLE)
+               set(PRIVATE_LIBS "${PRIVATE_LIBS} -l${LIB}")
+       endforeach()
+       CONFIGURE_FILE("libobs.pc.in" "libobs.pc" @ONLY)
+-      install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libobs.pc" DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/pkgconfig")
++      install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libobs.pc" DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
+ endif()
+ set_target_properties(libobs PROPERTIES
+diff --git a/libobs/libobs.pc.in b/libobs/libobs.pc.in
+index 03fe4cdd..f6c471ba 100644
+--- a/libobs/libobs.pc.in
++++ b/libobs/libobs.pc.in
+@@ -1,7 +1,7 @@
+-prefix=@DEST_DIR@
++prefix=@CMAKE_INSTALL_PREFIX@
+ exec_prefix=${prefix}
+-libdir=${prefix}/@OBS_LIBRARY_DESTINATION@
+-includedir=${prefix}/include
++libdir=@CMAKE_INSTALL_FULL_LIBDIR@
++includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
+ Name: libobs
+ Description: OBS Studio Library
+-- 
+2.22.0
+
diff --git a/media-video/obs-studio/obs-studio-23.2.1.ebuild b/media-video/obs-studio/obs-studio-23.2.1.ebuild
new file mode 100644 (file)
index 0000000..2b14f6e
--- /dev/null
@@ -0,0 +1,132 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+
+inherit cmake-utils python-single-r1 xdg-utils
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/obsproject/obs-studio.git"
+       EGIT_SUBMODULES=()
+else
+       SRC_URI="https://github.com/obsproject/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Software for Recording and Streaming Live Video Content"
+HOMEPAGE="https://obsproject.com"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa fdk imagemagick jack luajit nvenc pulseaudio python speex truetype v4l"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+BDEPEND="
+       luajit? ( dev-lang/swig )
+       python? ( dev-lang/swig )
+"
+DEPEND="
+       >=dev-libs/jansson-2.5
+       dev-qt/qtcore:5
+       dev-qt/qtdeclarative:5
+       dev-qt/qtgui:5
+       dev-qt/qtmultimedia:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtquickcontrols:5
+       dev-qt/qtsql:5
+       dev-qt/qtsvg:5
+       dev-qt/qttest:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       media-video/ffmpeg:=[x264]
+       net-misc/curl
+       x11-libs/libXcomposite
+       x11-libs/libXinerama
+       x11-libs/libXrandr
+       alsa? ( media-libs/alsa-lib )
+       fdk? ( media-libs/fdk-aac:= )
+       imagemagick? ( media-gfx/imagemagick:= )
+       jack? ( virtual/jack )
+       luajit? ( dev-lang/luajit:2 )
+       nvenc? (
+               || (
+                       <media-video/ffmpeg-4[nvenc]
+                       >=media-video/ffmpeg-4[video_cards_nvidia]
+               )
+       )
+       pulseaudio? ( media-sound/pulseaudio )
+       python? ( ${PYTHON_DEPS} )
+       speex? ( media-libs/speexdsp )
+       truetype? (
+               media-libs/fontconfig
+               media-libs/freetype
+       )
+       v4l? ( media-libs/libv4l )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES="${FILESDIR}/${PN}-23.2.1-use-correct-libdir.patch"
+
+CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+       local libdir=$(get_libdir)
+       local mycmakeargs=(
+               -DDISABLE_ALSA=$(usex !alsa)
+               -DDISABLE_FREETYPE=$(usex !truetype)
+               -DDISABLE_JACK=$(usex !jack)
+               -DDISABLE_LIBFDK=$(usex !fdk)
+               -DDISABLE_PULSEAUDIO=$(usex !pulseaudio)
+               -DDISABLE_SPEEXDSP=$(usex !speex)
+               -DDISABLE_V4L2=$(usex !v4l)
+               -DLIBOBS_PREFER_IMAGEMAGICK=$(usex imagemagick)
+               -DOBS_MULTIARCH_SUFFIX=${libdir#lib}
+               -DOBS_VERSION_OVERRIDE=${PV}
+               -DUNIX_STRUCTURE=1
+       )
+
+       if use luajit || use python; then
+               mycmakeargs+=(
+                       -DDISABLE_LUA=$(usex !luajit)
+                       -DDISABLE_PYTHON=$(usex !python)
+                       -DENABLE_SCRIPTING=yes
+               )
+       else
+               mycmakeargs+=( -DENABLE_SCRIPTING=no )
+       fi
+
+       cmake-utils_src_configure
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+
+       if ! use alsa && ! use pulseaudio; then
+               elog
+               elog "For the audio capture features to be available,"
+               elog "either the 'alsa' or the 'pulseaudio' USE-flag needs to"
+               elog "be enabled."
+               elog
+       fi
+
+       if ! has_version "sys-apps/dbus"; then
+               elog
+               elog "The 'sys-apps/dbus' package is not installed, but"
+               elog "could be used for disabling hibernating, screensaving,"
+               elog "and sleeping.  Where it is not installed,"
+               elog "'xdg-screensaver reset' is used instead"
+               elog "(if 'x11-misc/xdg-utils' is installed)."
+               elog
+       fi
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}