app-emulation/cadvisor: 0.36.0 bump
authorWilliam Hubbs <williamh@gentoo.org>
Fri, 13 Mar 2020 21:31:23 +0000 (16:31 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Fri, 13 Mar 2020 21:35:10 +0000 (16:35 -0500)
Signed-off-by: William Hubbs <williamh@gentoo.org>
app-emulation/cadvisor/Manifest
app-emulation/cadvisor/cadvisor-0.36.0.ebuild [new file with mode: 0644]

index 5c05e93fe26fff85935c97bf561884d0fa2c2078..8a9133dc6b8d2f3f2c0fdf7901fb86224d51c144 100644 (file)
@@ -1,2 +1,3 @@
 DIST cadvisor-0.34.0.tar.gz 5210189 BLAKE2B 48cf7ddc94e52f07a0e74868d00f4a45d45aa5233b518da46762743357c17cbe7f2971794deda9936a10c65724928a219c498bf6d2493266f5b0ea547d485cb6 SHA512 accb41afd4683413b846f9380229bfa54c88b3141be68492963444928e40e14fc28da3ce27b09746e29c4dfe6323cd6bea69181826367e830f284d6ab698c633
 DIST cadvisor-0.35.0.tar.gz 5268930 BLAKE2B 065619ee459062bb521e855ccfd576afe236863bdc203b65e53a7eb6aec7172b6b9bb1d4183667ed36c471becb09fd974d1e4f809cf614f4d0d03ea3b87c2f63 SHA512 9fdae170fd167e0b1a2b69112ff2ec081640a144490c04e364536cae71a90e2c2845857f35af81ec58d4addd3675fd86b045d1f1b99a3e281f6270ab5d2a70f3
+DIST cadvisor-0.36.0.tar.gz 6182273 BLAKE2B 0406bd88c6595f23de06be1e63e7c0affda7f94a3bbbb1b9e390f2747fdd3ef3199622a5003b79ed083a0cd80e6c013d7776e18269044150dafb98341c54425b SHA512 2da8a2e81d33b97e6f7c5ba3982e51b6d87748b138345ff94eb7671df851f0a535ceeef61358b0ee43bc161a88becdb153065bd7ff8fc9d7c390a4629ad10f02
diff --git a/app-emulation/cadvisor/cadvisor-0.36.0.ebuild b/app-emulation/cadvisor/cadvisor-0.36.0.ebuild
new file mode 100644 (file)
index 0000000..e98f371
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+COMMIT=4fe450a23991beb6c61dc941c0f87f56021ad386
+
+DESCRIPTION="Analyzes resource usage and performance characteristics of running containers"
+HOMEPAGE="https://github.com/google/cadvisor"
+SRC_URI="https://github.com/google/cadvisor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+COMMON_DEPEND="acct-group/cadvisor
+       acct-user/cadvisor"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+       sed -i -e "/go get/d" build/assets.sh || die
+       sed -i -e "s/git describe.*/echo ${PV} )/"\
+               -e "s/git rev-parse --short HEAD.*/echo ${COMMIT} )/"\
+               build/build.sh || die
+       default
+}
+
+src_compile() {
+       GO_FLAGS="-v -work -x" VERBOSE="true" emake build
+}
+
+src_install() {
+       newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
+       dobin ${PN}
+       keepdir /var/log/${PN}
+       fowners ${PN}:${PN} /var/log/${PN}
+}