app-text/jadetex: Add tl2019 support
authorMikle Kolyada <zlogene@gentoo.org>
Mon, 3 Jun 2019 17:06:02 +0000 (20:06 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Mon, 3 Jun 2019 17:06:02 +0000 (20:06 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

app-text/jadetex/jadetex-3.13-r7.ebuild

index 3a80cfceed76da8a07f2517e657f588ceb59c0ab..14d37d8b41f7f5b3c44c07dab7a9f2b292916931 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -20,9 +20,11 @@ DEPEND=">=app-text/openjade-1.3.1
        dev-texlive/texlive-plaingeneric"
 
 src_compile() {
+       fmt_call="$(has_version '>=app-text/texlive-core-2019' \
+         && echo "fmtutil-user" || echo "fmtutil")"
        VARTEXFONTS="${T}/fonts" emake
        VARTEXFONTS="${T}/fonts" TEXMFHOME="${S}" env -u TEXINPUTS \
-               fmtutil --cnffile "${FILESDIR}/format.jadetex.cnf" --fmtdir "${S}/texmf-var/web2c" --all\
+               $fmt_call --cnffile "${FILESDIR}/format.jadetex.cnf" --fmtdir "${S}/texmf-var/web2c" --all\
                                || die "failed to build format"
 }