dev-tex/newlfm: bump EAPI and stuff
authorAaron Bauman <bman@gentoo.org>
Sat, 9 Nov 2019 20:56:06 +0000 (15:56 -0500)
committerAaron Bauman <bman@gentoo.org>
Sat, 9 Nov 2019 20:56:06 +0000 (15:56 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-tex/newlfm/newlfm-8.3-r1.ebuild

index 367aae497dc8028ef25e6fe72fb20cfd874ddb1d..7ae106cc1e392314fa0a5490523fb7df9d6efe07 100644 (file)
@@ -1,12 +1,12 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit latex-package
 
 DESCRIPTION="Extensive LaTeX class for writing letters"
-HOMEPAGE="http://www.ctan.org/tex-archive/help/Catalogue/entries/newlfm.html"
+HOMEPAGE="https://www.ctan.org/tex-archive/help/Catalogue/entries/newlfm.html"
 # Downloaded from:
 # ftp://ftp.dante.de/tex-archive/macros/latex/contrib/newlfm.tar.gz
 SRC_URI="mirror://gentoo/${P}.tar.gz"
@@ -19,10 +19,11 @@ IUSE=""
 
 DEPEND="dev-texlive/texlive-latexextra"
 RDEPEND="${DEPEND}"
+
 S="${WORKDIR}/${PN}"
 
 src_compile() {
-       latex newlfm.ins || die
+       latex newlfm.ins || die "Latex compilation failed"
 }
 
 src_install() {