www-apps/gitea: remove 1.8.3
authorFelix Neumärker <xdch47@posteo.de>
Sat, 7 Dec 2019 17:42:20 +0000 (18:42 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 12 Dec 2019 17:53:34 +0000 (19:53 +0200)
Package-Manager: Portage-2.3.80, Repoman-2.3.20
Signed-off-by: Felix Neumärker <xdch47@posteo.de>
Closes: https://github.com/gentoo/gentoo/pull/13906
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
www-apps/gitea/Manifest
www-apps/gitea/gitea-1.8.3.ebuild [deleted file]

index 6a880b10aac80df201da72eeca365624a97aaccb..d33756c4087337b918faf47523f524a683cf7d41 100644 (file)
@@ -1,3 +1,2 @@
 DIST gitea-1.10.1.tar.gz 30146802 BLAKE2B d566e58bc8031c6ff2741861c93deb1cc0bbe2236cfa8d1f054e1453d39b294ae55bd3bae46373efa39cd0b5bc9dfc248ecc0c64642eb4df68fb01042ef1c692 SHA512 d7baea6ac9aca3a3226d36325000c71c886d560eeecb2fdbed924b4924db34882cdd82d07120e3c7175a6d87140a1f63cc575c3be44513e08f8e557856b39acd
-DIST gitea-1.8.3.tar.gz 24320679 BLAKE2B 9ef901ef7e1cb6ffa9a2aa082798b7a18ac2a6fdb4379082df3f942d767a27fd3915c7a4d2cb1af6f502a8cde3c1c98557c42d4c0ef60be7bdad78d8931035e0 SHA512 f6019fbfc056e4c7176222ccaca1cf638bd1f52323de54fcddc618129aeb778674f6e305de60e7d17b69505ad65439445ee6b5e368afdf0a6fbace7407acb495
 DIST gitea-1.9.5.tar.gz 25355286 BLAKE2B 8b733651de64fcafa7b41a6fc812fcad8ac7311a7e7acc679ec7dab759175ec13a096902aece209a3fef31eefd3a99493e13f7c9792e1e41b5a1c3376680d3ca SHA512 f7a04d3bb37a33da15290355f3f02ff4c1b737e8458cf65f731c870ac9e452243b1fdacc5f74accf963fb00cdd200dd31191058eb1d6dda8b1033846a961c7d3
diff --git a/www-apps/gitea/gitea-1.8.3.ebuild b/www-apps/gitea/gitea-1.8.3.ebuild
deleted file mode 100644 (file)
index bdefa9b..0000000
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit golang-vcs-snapshot systemd user
-
-EGO_PN="code.gitea.io/gitea"
-
-DESCRIPTION="A painless self-hosted Git service"
-HOMEPAGE="https://gitea.io"
-SRC_URI="https://github.com/go-gitea/gitea/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64"
-IUSE="pam sqlite"
-
-COMMON_DEPEND="pam? ( sys-libs/pam )"
-DEPEND="${COMMON_DEPEND}
-       dev-go/go-bindata"
-RDEPEND="${COMMON_DEPEND}
-       dev-vcs/git"
-
-DOCS=( custom/conf/app.ini.sample CONTRIBUTING.md README.md )
-S="${WORKDIR}/${P}/src/${EGO_PN}"
-
-pkg_setup() {
-       enewgroup git
-       enewuser git -1 /bin/bash /var/lib/gitea git
-}
-
-gitea_make() {
-       local my_tags=(
-               bindata
-               $(usev pam)
-               $(usex sqlite 'sqlite sqlite_unlock_notify' '')
-       )
-       local my_makeopt=(
-               DRONE_TAG=${PV}
-               TAGS="${my_tags[@]}"
-       )
-       GOPATH=${WORKDIR}/${P}:$(get_golibdir_gopath) emake "${my_makeopt[@]}" "$@"
-}
-
-src_prepare() {
-       default
-       sed -i \
-               -e "s#^RUN_MODE = dev#RUN_MODE = prod#"                                     \
-               -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"          \
-               -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"                   \
-               -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#" \
-               -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"                          \
-               -e "s#^MODE = console#MODE = file#"                                         \
-               -e "s#^LEVEL = Trace#LEVEL = Info#"                                         \
-               -e "s#^LOG_SQL = true#LOG_SQL = false#"                                     \
-               -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"               \
-               -e "s#^APP_ID =#;APP_ID =#"                                                 \
-               -e "s#^TRUSTED_FACETS =#;TRUSTED_FACETS =#"                                 \
-               custom/conf/app.ini.sample || die
-       if use sqlite ; then
-               sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.ini.sample || die
-       fi
-
-       gitea_make generate
-}
-
-src_compile() {
-       gitea_make build
-}
-
-src_test() {
-       gitea_make test
-}
-
-src_install() {
-       dobin gitea
-
-       einstalldocs
-
-       newconfd "${FILESDIR}"/gitea.confd-r1 gitea
-       newinitd "${FILESDIR}"/gitea.initd-r3 gitea
-       systemd_newunit "${FILESDIR}"/gitea.service-r2 gitea.service
-
-       insinto /etc/gitea
-       newins custom/conf/app.ini.sample app.ini
-       fowners root:git /etc/gitea/{,app.ini}
-       fperms g+w,o-rwx /etc/gitea/{,app.ini}
-
-       diropts -m0750 -o git -g git
-       keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
-       keepdir /var/log/gitea
-}
-
-pkg_postinst() {
-       if [[ -e "${EROOT}/var/lib/gitea/conf/app.ini" ]]; then
-               ewarn "The configuration path has been changed to ${EROOT}/etc/gitea/app.ini."
-               ewarn "Please move your configuration from ${EROOT}/var/lib/gitea/conf/app.ini"
-               ewarn "and adapt the gitea-repositories hooks and ssh authorized_keys."
-               ewarn "Depending on your configuration you should run something like:"
-               ewarn "sed -i -e 's#${EROOT}/var/lib/gitea/conf/app.ini#${EROOT}/etc/gitea/app.ini#' \\"
-               ewarn "  /var/lib/gitea/gitea-repositories/*/*/hooks/*/* \\"
-               ewarn "  /var/lib/gitea/.ssh/authorized_keys"
-       fi
-}