dev-python/numpy: fix regressions introduced by 48dd16c7839fd.
authorBenda Xu <heroxbd@gentoo.org>
Mon, 27 Apr 2020 10:03:44 +0000 (18:03 +0800)
committerBenda Xu <heroxbd@gentoo.org>
Mon, 27 Apr 2020 10:06:39 +0000 (18:06 +0800)
Bug: https://github.com/gentoo/gentoo/pull/15315
Closes: https://bugs.gentoo.org/660754
Package-Manager: Portage-2.3.88, Repoman-2.3.18
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
dev-python/numpy/numpy-1.18.3.ebuild
profiles/arch/powerpc/package.use.mask
profiles/arch/sparc/package.use.mask

index 274e9fd371f268820efd3bd9f6185205222e5902..05e59611dcc7ba93bc0a87b73b8e14f0fe0fa2a4 100644 (file)
@@ -10,7 +10,7 @@ FORTRAN_NEEDED=lapack
 
 DISTUTILS_USE_SETUPTOOLS=rdepend
 
-inherit autotools distutils-r1 flag-o-matic fortran-2 multiprocessing toolchain-funcs
+inherit distutils-r1 flag-o-matic fortran-2 multiprocessing toolchain-funcs
 
 DOC_PV="1.16.4"
 DESCRIPTION="Fast array and numerical python library"
@@ -24,7 +24,7 @@ SRC_URI="
        )"
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
 IUSE="doc lapack"
 
 RDEPEND="
@@ -37,11 +37,7 @@ BDEPEND="
        ${RDEPEND}
        app-arch/unzip
        >=dev-python/cython-0.29.15[${PYTHON_USEDEP}]
-       lapack? (
-               >=sys-devel/automake-1.16.2
-               >=sys-devel/gcc-6.5.0-r1[fortran]
-               virtual/pkgconfig
-       )
+       lapack? ( virtual/pkgconfig )
        test? (
                >=dev-python/hypothesis-5.8.0[${PYTHON_USEDEP}]
                >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
@@ -62,11 +58,6 @@ src_unpack() {
        fi
 }
 
-src_prepare() {
-       default
-       eautomake
-}
-
 python_prepare_all() {
        if use lapack; then
                local incdir="${EPREFIX}"/usr/include
@@ -118,6 +109,8 @@ python_prepare_all() {
 }
 
 python_compile() {
+       export MAKEOPTS=-j1 #660754
+
        distutils-r1_python_compile ${NUMPY_FCONFIG}
 }
 
index 8baff9448146576d22ce9803e66be0b51f97d79d..9219f7cf2a439e06fd439f294d3ee6824d604266 100644 (file)
@@ -1,6 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
+# Benda Xu <heroxbd@gentoo.org> (2020-04-27)
+# tests optionally depend on dev-python/hypothesis
+dev-python/numpy test
+
 # Lars Wendler <polynomial-c@gentoo.org> (2020-04-20)
 # Not keyworded on ppc
 net-misc/whois xcrypt
index 5eed363d11a2ae1ad55db642f204b5bf1e47417d..5be369d76faf2865f38cf6f8b106af31bd488bb2 100644 (file)
@@ -1,6 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
+# Benda Xu <heroxbd@gentoo.org> (2020-04-27)
+# tests optionally depend on dev-python/hypothesis
+dev-python/numpy test
+
 # Rolf Eike Beer <eike@sf-mail.de> (2020-04-26)
 # tests optionally depend on dev-ruby/coffee-script needing nodejs
 dev-ruby/tilt test