dev-ros/image_proc: Backport upstream patch to build with gcc6.
authorAlexis Ballier <aballier@gentoo.org>
Mon, 23 Jan 2017 12:22:18 +0000 (13:22 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 23 Jan 2017 12:28:12 +0000 (13:28 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ros/image_proc/files/gcc6.patch [new file with mode: 0644]
dev-ros/image_proc/image_proc-1.12.19.ebuild

diff --git a/dev-ros/image_proc/files/gcc6.patch b/dev-ros/image_proc/files/gcc6.patch
new file mode 100644 (file)
index 0000000..88a8d9b
--- /dev/null
@@ -0,0 +1,32 @@
+commit 6c2d65452bd5fe62723988a1a570789921900d59
+Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+Date:   Fri Sep 30 15:39:47 2016 +0200
+
+    address gcc6 build error
+    
+    With gcc6, compiling fails with `stdlib.h: No such file or directory`,
+    as including '-isystem /usr/include' breaks with gcc6, cf.,
+    https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
+    
+    This commit addresses this issue for this package in the same way
+    it was addressed in various other ROS packages. A list of related
+    commits and pull requests is at:
+    
+      https://github.com/ros/rosdistro/issues/12783
+    
+    Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+
+diff --git a/image_proc/CMakeLists.txt b/image_proc/CMakeLists.txt
+index a13371f..34905f0 100755
+--- a/image_proc/CMakeLists.txt
++++ b/image_proc/CMakeLists.txt
+@@ -17,8 +17,7 @@ catkin_package(
+   LIBRARIES ${PROJECT_NAME}
+ )
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
+-include_directories(include)
++include_directories(include ${catkin_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
+ # Nodelet library
+ add_library(${PROJECT_NAME} src/libimage_proc/processor.cpp
index 08dd3217ec2f6df4602712002e37355f98b057ec..72fc4380ed71a61d6ade8353670f6a0e3f91314c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -27,3 +27,4 @@ RDEPEND="
        dev-libs/boost:=[threads]
 "
 DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )