media-sound/opus-tools: use https for HOMEPAGE, SRC_URI, and git repo
authorTim Harder <radhermit@gentoo.org>
Thu, 31 Aug 2017 13:20:02 +0000 (09:20 -0400)
committerTim Harder <radhermit@gentoo.org>
Thu, 31 Aug 2017 13:20:02 +0000 (09:20 -0400)
media-sound/opus-tools/opus-tools-0.1.10.ebuild

index aaca61a106f3c0a955f366462820dddf201afe35..652f98ca96937040d7a9fbac5963acf3b1ceb554 100644 (file)
@@ -5,15 +5,15 @@ EAPI=6
 inherit autotools
 
 DESCRIPTION="Royalty-free, highly versatile audio codec"
-HOMEPAGE="http://opus-codec.org/"
+HOMEPAGE="https://opus-codec.org/"
 
 if [[ ${PV} == *9999 ]] ; then
-       inherit git-2
-       EGIT_REPO_URI="git://git.opus-codec.org/${PN}.git"
+       inherit git-r3
+       EGIT_REPO_URI="https://git.xiph.org/opus-tools.git"
 elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
        SRC_URI="https://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
 else # Official release
-       SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+       SRC_URI="https://downloads.xiph.org/releases/opus/${P}.tar.gz"
 fi
 
 LICENSE="BSD-2"