dev-python/multidict: version bump to 4.3.1
authorTim Harder <radhermit@gentoo.org>
Fri, 1 Jun 2018 08:01:35 +0000 (04:01 -0400)
committerTim Harder <radhermit@gentoo.org>
Mon, 4 Jun 2018 23:33:27 +0000 (19:33 -0400)
dev-python/multidict/Manifest
dev-python/multidict/multidict-4.3.1.ebuild [new file with mode: 0644]

index b50b10cebb6f235bd38ae54cf86f60bae42e1992..9dec4062a5c77fa1e2a50c677d3396fc948b6d53 100644 (file)
@@ -6,3 +6,4 @@ DIST multidict-2.1.4.tar.gz 28395 BLAKE2B deb08b2d1039aebc95b5c7b63261180847ef65
 DIST multidict-2.1.5.tar.gz 28497 BLAKE2B 301248a428f3be7740dd04ccc8ae5e92d971736b04f7243949805ffcdd005c68b20340146dee690055554dee814354770269e48bda82094f35a4668b4ac7a61a SHA512 927f2e0c175e52edbf3a5385957e5988a08061160488df70f7431520ef75439011986365dfebac80e8da6e1874232c532ea96c53081c65c74c04f0e307db6729
 DIST multidict-3.3.2.tar.gz 40083 BLAKE2B 6622efd489d4f0046200b6b28a158306cff7a3e463688c512827b599500956793ac27f6ee839e076a921b84665bc932274a5ebf4c37e273fc02916dc9be1eed7 SHA512 d44c8b00ab7823b8840665aa1462ed547aea48874a408b2af8f1cb455727896cd77ef2201e8f234bcb3f2781599ffe931a5884fc55fc1f7286da29185c4d88fc
 DIST multidict-4.1.0.tar.gz 43492 BLAKE2B 4d53a12896f070fd029816742ccff11a12636164e51215bb22b368da10d555d52a9ab7d5dc4632baec9ebc628ca4f846ad7fb2ad0bb044f033fd7e567cda0da8 SHA512 8972ca48146b40fd88f5b0675ed6d45e6887c31fc1d5962203f0fa77a369ef11b0d7739593f5691ae1fd2bbef989940983ddcf0c09acfc5a65b39b6b336571f9
+DIST multidict-4.3.1.tar.gz 45342 BLAKE2B 12a0a8f0785c30e393d996c506a69d6ba03227e47040d46859e1289b47ce23b49a9bed48c3cb0b26f3bf4051cce3963d020a92ed28373038fb79b2204c13d380 SHA512 1b475836c776ddddfdc4f14882df41f9956ab06afac7b640e3f5ae3c50717f2b07267acbae2fa3e94cf8c5650273d4d7ce44329c0febea95046ee27d98db9288
diff --git a/dev-python/multidict/multidict-4.3.1.ebuild b/dev-python/multidict/multidict-4.3.1.ebuild
new file mode 100644 (file)
index 0000000..02df4b8
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="multidict implementation"
+HOMEPAGE="https://github.com/aio-libs/multidict/"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/cython[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_prepare_all() {
+       # don't use pytest-runner for tests
+       sed -i "s|'pytest-runner'||" setup.py || die
+
+       # don't enable coverage or other pytest settings
+       rm pytest.ini || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       py.test -v tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+       distutils-r1_python_install_all
+}