projects
/
portage.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7429253
)
Always ignore hidden files when generating Manifests. Thanks to Christian
author
Zac Medico
<zmedico@gentoo.org>
Wed, 11 Mar 2009 03:30:14 +0000
(
03:30
-0000)
committer
Zac Medico
<zmedico@gentoo.org>
Wed, 11 Mar 2009 03:30:14 +0000
(
03:30
-0000)
Ruppert for reporting. (trunk r12566)
svn path=/main/branches/2.1.6/; revision=12847
pym/portage/manifest.py
patch
|
blob
|
history
diff --git
a/pym/portage/manifest.py
b/pym/portage/manifest.py
index 384da250a13ee9239fce83a3c35b4c0825eb8dbc..0fc0a6b4a2a2c28719a005549685c2a76bc52c9c 100644
(file)
--- a/
pym/portage/manifest.py
+++ b/
pym/portage/manifest.py
@@
-291,7
+291,9
@@
class Manifest(object):
for pkgdir, pkgdir_dirs, pkgdir_files in os.walk(self.pkgdir):
break
for f in pkgdir_files:
- if f.endswith(".ebuild"):
+ if f[:1] == ".":
+ continue
+ elif f[-7:] == ".ebuild":
mytype = "EBUILD"
pf = f[:-7]
ps = portage.versions.pkgsplit(pf)