dev-python/pykwalify: Sync the live ebuild
authorMichał Górny <mgorny@gentoo.org>
Fri, 5 Jul 2019 09:41:01 +0000 (11:41 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 5 Jul 2019 09:44:59 +0000 (11:44 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pykwalify/pykwalify-9999.ebuild

index 60facbc65fa05b6c6040ce2dfec687b0da45ceaf..37c94c83063d34aed5621fb3eadfd2d2e4e29b53 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
 
 inherit distutils-r1 git-r3
 
@@ -18,13 +18,15 @@ KEYWORDS=""
 IUSE="test"
 
 RDEPEND="
-       >=dev-python/docopt-0.6.2
-       >=dev-python/pyyaml-3.11
-       >=dev-python/python-dateutil-2.4.2
+       >=dev-python/docopt-0.6.2[${PYTHON_USEDEP}]
+       >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
+       >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
 "
-DEPEND="${RDEPEND}
+DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
+               ${RDEPEND}
                dev-python/pytest[${PYTHON_USEDEP}]
                dev-python/testfixtures[${PYTHON_USEDEP}]
        )
@@ -33,5 +35,5 @@ DEPEND="${RDEPEND}
 PATCHES=( "${FILESDIR}"/${PN}-1.4.0-S.patch )
 
 python_test() {
-       py.test || die
+       pytest -vv || die
 }