media-libs/libsdl2: Apply gles to gles2 USE rename to stable
authorJames Le Cuirot <chewi@gentoo.org>
Mon, 6 Apr 2020 08:22:28 +0000 (09:22 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Mon, 6 Apr 2020 18:50:53 +0000 (19:50 +0100)
Easier than fixing the consuming ebuilds.

Package-Manager: Portage-2.3.96, Repoman-2.3.20
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
media-libs/libsdl2/libsdl2-2.0.10-r1.ebuild [moved from media-libs/libsdl2/libsdl2-2.0.10.ebuild with 93% similarity]
media-libs/libsdl2/metadata.xml

similarity index 93%
rename from media-libs/libsdl2/libsdl2-2.0.10.ebuild
rename to media-libs/libsdl2/libsdl2-2.0.10-r1.ebuild
index a5b740c0bd032ca46fd6d8dca240e2ec768fdae2..972572986682e651f58b6e3d807a7b00a8ff909a 100644 (file)
@@ -13,22 +13,22 @@ LICENSE="ZLIB"
 SLOT="0"
 KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
 
-IUSE="cpu_flags_x86_3dnow alsa altivec aqua custom-cflags dbus gles haptic libsamplerate +joystick kms cpu_flags_x86_mmx nas opengl oss pulseaudio +sound cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs +threads tslib udev +video video_cards_vc4 vulkan wayland X xinerama xscreensaver"
+IUSE="cpu_flags_x86_3dnow alsa altivec aqua custom-cflags dbus gles2 haptic libsamplerate +joystick kms cpu_flags_x86_mmx nas opengl oss pulseaudio +sound cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs +threads tslib udev +video video_cards_vc4 vulkan wayland X xinerama xscreensaver"
 REQUIRED_USE="
        alsa? ( sound )
-       gles? ( video )
+       gles2? ( video )
        nas? ( sound )
        opengl? ( video )
        pulseaudio? ( sound )
        vulkan? ( video )
-       wayland? ( gles )
+       wayland? ( gles2 )
        xinerama? ( X )
        xscreensaver? ( X )"
 
 CDEPEND="
        alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
        dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
-       gles? ( >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},gles2] )
+       gles2? ( >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},gles2] )
        kms? (
                >=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
                >=media-libs/mesa-9.0.0[${MULTILIB_USEDEP},gbm]
@@ -157,7 +157,7 @@ multilib_src_configure() {
                $(use_enable video video-dummy)
                $(use_enable opengl video-opengl)
                --disable-video-opengles1
-               $(use_enable gles video-opengles2)
+               $(use_enable gles2 video-opengles2)
                $(use_enable vulkan video-vulkan)
                $(use_enable udev libudev)
                $(use_enable dbus)
index 37b2b85772357dea9369735139ba9e03194fa84f..ec21c0415ca4fdbe1202480cdae032297c924bea 100644 (file)
@@ -24,7 +24,6 @@
                Perl, PHP, Pike, Python, and Ruby.
        </longdescription>
        <use>
-               <flag name="gles">include OpenGL ES 2.0 support</flag>
                <flag name="gles2">include OpenGL ES 2.0 support</flag>
                <flag name="haptic">Enable the haptic (force feedback) subsystem</flag>
                <flag name="joystick">Control joystick support (disable at your own risk)</flag>