Convert to use elog.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Fri, 5 Jan 2007 16:51:31 +0000 (16:51 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Fri, 5 Jan 2007 16:51:31 +0000 (16:51 +0000)
Package-Manager: portage-2.1.2_rc4-r6

19 files changed:
dev-ruby/bluecloth/ChangeLog
dev-ruby/bluecloth/bluecloth-1.0.0.ebuild
dev-ruby/capistrano/ChangeLog
dev-ruby/capistrano/capistrano-1.1.0.ebuild
dev-ruby/jabber4r/ChangeLog
dev-ruby/jabber4r/jabber4r-0.8.0.ebuild
dev-ruby/mod_ruby/ChangeLog
dev-ruby/mod_ruby/mod_ruby-1.2.2.ebuild
dev-ruby/mod_ruby/mod_ruby-1.2.4.ebuild
dev-ruby/mysql-ruby/ChangeLog
dev-ruby/mysql-ruby/mysql-ruby-2.7.2.ebuild
dev-ruby/mysql-ruby/mysql-ruby-2.7.ebuild
dev-ruby/pdf-writer/ChangeLog
dev-ruby/pdf-writer/pdf-writer-1.1.3.ebuild
dev-ruby/redcloth/ChangeLog
dev-ruby/redcloth/redcloth-3.0.3.ebuild
dev-ruby/redcloth/redcloth-3.0.4.ebuild
dev-ruby/rubytorrent/ChangeLog
dev-ruby/rubytorrent/rubytorrent-0.3.ebuild

index 357f1399edaaab7a6695a846159645fd48532258..0fe03df0399b9953fdd989bcae77c2278cfacbbe 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-ruby/bluecloth
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.6 2006/07/13 05:14:11 agriffis Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.7 2007/01/05 16:42:00 flameeyes Exp $
+
+  05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> bluecloth-1.0.0.ebuild:
+  Convert to use elog.
 
   13 Jul 2006; Aron Griffis <agriffis@gentoo.org> bluecloth-1.0.0.ebuild:
   Mark 1.0.0 stable on ia64
index 61d007e7320f97a60ad7e9794048bfbb3bd90644..5486ebd421f24a775762d5aa392492b8685563df 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-1.0.0.ebuild,v 1.6 2006/07/13 05:14:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-1.0.0.ebuild,v 1.7 2007/01/05 16:42:00 flameeyes Exp $
 
 inherit ruby gems
 
@@ -20,11 +20,11 @@ DEPEND=">=dev-lang/ruby-1.8"
 S=${WORKDIR}/${MY_P}
 
 pkg_postinst() {
-       einfo "This package was installed using a 'gem'."
-       einfo "If you are intending to write code which"
-       einfo "requires ${PN}, you will need to"
-       einfo
-       einfo "require 'rubygems'"
-       einfo
-       einfo "before requiring '${PN}'."
+       elog "This package was installed using a 'gem'."
+       elog "If you are intending to write code which"
+       elog "requires ${PN}, you will need to"
+       elog
+       elog "require 'rubygems'"
+       elog
+       elog "before requiring '${PN}'."
 }
index 3fdc68794f6c498f1c33621f1c16f6686bc87b99..e74ef6af72d46c2a61141cafe44bceca4aae811b 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for dev-ruby/capistrano
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.5 2006/11/11 17:24:21 peper Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.6 2007/01/05 16:42:57 flameeyes Exp $
+
+  05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+  capistrano-1.1.0.ebuild:
+  Convert to use elog.
 
   11 Nov 2006; Piotr Jaroszyński <peper@gentoo.org>
   capistrano-1.1.0.ebuild:
index f51d77af262a74d83c168d18680c5b3683669eb8..5fae78fcfa57ea4000f6478ed139ba71578580c8 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-1.1.0.ebuild,v 1.4 2006/11/11 17:24:21 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-1.1.0.ebuild,v 1.5 2007/01/05 16:42:57 flameeyes Exp $
 
 inherit ruby gems
 
@@ -22,9 +22,9 @@ DEPEND=">=dev-lang/ruby-1.8.2
 
 pkg_postinst()
 {
-       einfo
-       einfo "Capistrano has replaced switchtower due to naming issues.  If you were previously using"
-       einfo "switchtower in your Rails apps, you need to manuall remove lib/tasks/switchtower.rake"
-       einfo "from them and then run 'cap -A .' in your project director, making sure to keep deploy.rb"
-       einfo
+       elog
+       elog "Capistrano has replaced switchtower due to naming issues.  If you were previously using"
+       elog "switchtower in your Rails apps, you need to manuall remove lib/tasks/switchtower.rake"
+       elog "from them and then run 'cap -A .' in your project director, making sure to keep deploy.rb"
+       elog
 }
index d852c535d8abe2c42a7ff12fcc27b5118d6559a3..ef0d555826a7de33872b87f541489e11b901e4cc 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-ruby/jabber4r
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jabber4r/ChangeLog,v 1.4 2006/07/13 05:21:05 agriffis Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jabber4r/ChangeLog,v 1.5 2007/01/05 16:46:26 flameeyes Exp $
+
+  05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> jabber4r-0.8.0.ebuild:
+  Convert to use elog.
 
   13 Jul 2006; Aron Griffis <agriffis@gentoo.org> jabber4r-0.8.0.ebuild:
   Mark 0.8.0 stable on ia64
index 0cbc13bf3289d0f3b5cb9fa66425c494521028d4..9611b56f68c45a8648b324adbbd671400e012c13 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jabber4r/jabber4r-0.8.0.ebuild,v 1.4 2006/07/13 05:21:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jabber4r/jabber4r-0.8.0.ebuild,v 1.5 2007/01/05 16:46:26 flameeyes Exp $
 
 inherit ruby gems
 
@@ -17,11 +17,11 @@ USE_RUBY="ruby18 ruby19"
 DEPEND="virtual/ruby"
 
 pkg_postinst() {
-       einfo "This package was installed using a 'gem'."
-       einfo "If you are intending to write code which"
-       einfo "requires ${PN}, you will need to"
-       einfo
-       einfo "require 'rubygems'"
-       einfo
-       einfo "before requiring '${PN}'."
+       elog "This package was installed using a 'gem'."
+       elog "If you are intending to write code which"
+       elog "requires ${PN}, you will need to"
+       elog
+       elog "require 'rubygems'"
+       elog
+       elog "before requiring '${PN}'."
 }
index d52900e4453e6d815412660042b1044b0ae429c2..ee3485030a0118e2632ca2e5265911541e48b389 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for dev-ruby/mod_ruby
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod_ruby/ChangeLog,v 1.20 2006/10/20 19:18:37 agriffis Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod_ruby/ChangeLog,v 1.21 2007/01/05 16:47:32 flameeyes Exp $
+
+  05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> mod_ruby-1.2.2.ebuild,
+  mod_ruby-1.2.4.ebuild:
+  Convert to use elog.
 
   20 Oct 2006; Aron Griffis <agriffis@gentoo.org> mod_ruby-1.2.4-r2.ebuild:
   Mark 1.2.4-r2 stable on alpha
index 7c070f83a166150b8c010ff3704efbfe4c520999..2a3a5de959b6a88411eab13a340b8f55f4c37b32 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod_ruby/mod_ruby-1.2.2.ebuild,v 1.7 2005/12/14 17:00:00 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod_ruby/mod_ruby-1.2.2.ebuild,v 1.8 2007/01/05 16:47:32 flameeyes Exp $
 
 DESCRIPTION="Embeds the Ruby interpreter into Apache"
 HOMEPAGE="http://modruby.net/"
@@ -62,14 +62,14 @@ src_install() {
 
 pkg_postinst() {
        if apache2-detect ; then
-               einfo "To enable mod_ruby, edit /etc/conf.d/apache2 and add \"-D RUBY\""
-               einfo "You may also wish to edit /etc/apache2/conf/modules.d/20_mod_ruby.conf"
+               elog "To enable mod_ruby, edit /etc/conf.d/apache2 and add \"-D RUBY\""
+               elog "You may also wish to edit /etc/apache2/conf/modules.d/20_mod_ruby.conf"
        else    # apache1
-               einfo "To enable mod_ruby:"
-               einfo "1. Run \"emerge --config =${PF}\""
-               einfo "2. Edit /etc/conf.d/apache and add \"-D RUBY\""
+               elog "To enable mod_ruby:"
+               elog "1. Run \"emerge --config =${PF}\""
+               elog "2. Edit /etc/conf.d/apache and add \"-D RUBY\""
        fi
-       einfo "You must restart apache for changes to take effect"
+       elog "You must restart apache for changes to take effect"
 }
 
 pkg_config() {
index 35d8f379bc5aa0f6d1a117eb1b1b901156c1771b..79164b7ac68354aac34a6d9c7748a5f48a5ca818 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod_ruby/mod_ruby-1.2.4.ebuild,v 1.8 2005/12/14 17:00:00 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod_ruby/mod_ruby-1.2.4.ebuild,v 1.9 2007/01/05 16:47:32 flameeyes Exp $
 
 DESCRIPTION="Embeds the Ruby interpreter into Apache"
 HOMEPAGE="http://modruby.net/"
@@ -62,14 +62,14 @@ src_install() {
 
 pkg_postinst() {
        if apache2-detect ; then
-               einfo "To enable mod_ruby, edit /etc/conf.d/apache2 and add \"-D RUBY\""
-               einfo "You may also wish to edit /etc/apache2/conf/modules.d/20_mod_ruby.conf"
+               elog "To enable mod_ruby, edit /etc/conf.d/apache2 and add \"-D RUBY\""
+               elog "You may also wish to edit /etc/apache2/conf/modules.d/20_mod_ruby.conf"
        else    # apache1
-               einfo "To enable mod_ruby:"
-               einfo "1. Run \"emerge --config =${PF}\""
-               einfo "2. Edit /etc/conf.d/apache and add \"-D RUBY\""
+               elog "To enable mod_ruby:"
+               elog "1. Run \"emerge --config =${PF}\""
+               elog "2. Edit /etc/conf.d/apache and add \"-D RUBY\""
        fi
-       einfo "You must restart apache for changes to take effect"
+       elog "You must restart apache for changes to take effect"
 }
 
 pkg_config() {
index 1fb853c1ca3004efc56030bbf7298a31f5e13acb..6d260f9861fd96bb376ca10a85f467bafd3211b8 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for dev-ruby/mysql-ruby
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mysql-ruby/ChangeLog,v 1.29 2006/12/07 15:58:51 pclouds Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mysql-ruby/ChangeLog,v 1.30 2007/01/05 16:48:20 flameeyes Exp $
+
+  05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> mysql-ruby-2.7.ebuild,
+  mysql-ruby-2.7.2.ebuild:
+  Convert to use elog.
 
 *mysql-ruby-2.7.2 (07 Dec 2006)
 
index 25bf73fa49ca37873ca87190a47c1a2e47633021..491584feccd36f124c141ca6db4ad6ff0948a25e 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mysql-ruby/mysql-ruby-2.7.2.ebuild,v 1.1 2006/12/07 15:58:51 pclouds Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mysql-ruby/mysql-ruby-2.7.2.ebuild,v 1.2 2007/01/05 16:48:20 flameeyes Exp $
 
 inherit ruby
 
@@ -29,12 +29,12 @@ src_install() {
 }
 
 src_test() {
-       einfo
-       einfo "To test the programme you need to start mysql first."
-       einfo "Then extract the tarball and run"
-       einfo
-       einfo " % ruby test.rb hostname user password"
-       einfo
-       einfo "See /usr/share/doc/${PF}/html/README.html for detail."
-       einfo
+       elog
+       elog "To test the programme you need to start mysql first."
+       elog "Then extract the tarball and run"
+       elog
+       elog "  % ruby test.rb hostname user password"
+       elog
+       elog "See /usr/share/doc/${PF}/html/README.html for detail."
+       elog
 }
index 7761fcde0f8fb7eeb3ae6c576008771e5e5cee53..178450f0846b2f164dc639111f22d5795a34a38d 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mysql-ruby/mysql-ruby-2.7.ebuild,v 1.11 2006/11/23 19:38:25 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mysql-ruby/mysql-ruby-2.7.ebuild,v 1.12 2007/01/05 16:48:20 flameeyes Exp $
 
 inherit ruby
 
@@ -29,12 +29,12 @@ src_install() {
 }
 
 src_test() {
-       einfo
-       einfo "To test the programme you need to start mysql first."
-       einfo "Then extract the tarball and run"
-       einfo
-       einfo " % ruby test.rb hostname user password"
-       einfo
-       einfo "See /usr/share/doc/${PF}/html/README.html for detail."
-       einfo
+       elog
+       elog "To test the programme you need to start mysql first."
+       elog "Then extract the tarball and run"
+       elog
+       elog "  % ruby test.rb hostname user password"
+       elog
+       elog "See /usr/share/doc/${PF}/html/README.html for detail."
+       elog
 }
index ae2efa4b5ebd16e48dbab95a97f915fd77f13894..1dfbb797c21706b634e949a73fceca17dbf67de6 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for dev-ruby/pdf-writer
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-writer/ChangeLog,v 1.7 2006/10/20 21:53:55 agriffis Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-writer/ChangeLog,v 1.8 2007/01/05 16:49:09 flameeyes Exp $
+
+  05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+  pdf-writer-1.1.3.ebuild:
+  Convert to use elog.
 
   20 Oct 2006; Aron Griffis <agriffis@gentoo.org> pdf-writer-1.1.3.ebuild:
   Mark 1.1.3 stable on ia64
index 5df3e942285a3a2f73358c8ef237a9c69001543b..bd9a54caad8c11a429dd5837db7f480d8e92a631 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-writer/pdf-writer-1.1.3.ebuild,v 1.4 2006/10/20 21:53:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-writer/pdf-writer-1.1.3.ebuild,v 1.5 2007/01/05 16:49:09 flameeyes Exp $
 
 inherit ruby gems
 
@@ -18,12 +18,12 @@ DEPEND=">=dev-ruby/color-tools-1.3.0
        >=dev-ruby/transaction-simple-1.3.0"
 
 pkg_postinst() {
-       einfo "This package was installed using a 'gem'."
-       einfo "If you are intending to write code which"
-       einfo "requires ${PN}, you will need to"
-       einfo
-       einfo "require 'rubygems'"
-       einfo
-       einfo "before requiring '${PN}'."
+       elog "This package was installed using a 'gem'."
+       elog "If you are intending to write code which"
+       elog "requires ${PN}, you will need to"
+       elog
+       elog "require 'rubygems'"
+       elog
+       elog "before requiring '${PN}'."
 }
 
index 59f31c60ed883d69a719c50ea9bbb6dc3a8a143a..3662c6fc1d4e60730cb68dd40ba989a4ba63ddfc 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for dev-ruby/redcloth
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.12 2006/07/13 05:24:59 agriffis Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.13 2007/01/05 16:50:19 flameeyes Exp $
+
+  05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> redcloth-3.0.3.ebuild,
+  redcloth-3.0.4.ebuild:
+  Convert to use elog.
 
   13 Jul 2006; Aron Griffis <agriffis@gentoo.org> redcloth-3.0.4.ebuild:
   Mark 3.0.4 stable on ia64
index 8c6bf595b36cfbf57f9911c0bd585640a75af99e..2a8f3aaa1650cb580450f7fcb5c384ed3cf77ef0 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-3.0.3.ebuild,v 1.5 2006/03/30 03:42:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-3.0.3.ebuild,v 1.6 2007/01/05 16:50:19 flameeyes Exp $
 
 inherit ruby gems
 
@@ -21,15 +21,15 @@ S=${WORKDIR}/${MY_P}
 
 
 pkg_postinst() {
-       einfo "NOTE: This package is now installed via a 'gem'."
-       einfo "Previous versions used a standard tarball."
-       einfo "No packages in portage required ${PN}, so you won't be affected unless"
-       einfo "you have written ruby code which requires ${PN}. In that case you'll need"
-       einfo "to add this:"
-       einfo
-       einfo "require 'rubygems'"
-       einfo
-       einfo "before:"
-       einfo "require '${PN}'"
+       elog "NOTE: This package is now installed via a 'gem'."
+       elog "Previous versions used a standard tarball."
+       elog "No packages in portage required ${PN}, so you won't be affected unless"
+       elog "you have written ruby code which requires ${PN}. In that case you'll need"
+       elog "to add this:"
+       elog
+       elog "require 'rubygems'"
+       elog
+       elog "before:"
+       elog "require '${PN}'"
 }
 
index 9c96859b37bae6d09c2963a0cb11191240ef7b8a..eae0266db6332ab3e39fc756540d5ff64fedfb0e 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-3.0.4.ebuild,v 1.4 2006/07/13 05:24:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-3.0.4.ebuild,v 1.5 2007/01/05 16:50:19 flameeyes Exp $
 
 inherit ruby gems
 
@@ -21,15 +21,15 @@ S=${WORKDIR}/${MY_P}
 
 
 pkg_postinst() {
-       einfo "NOTE: This package is now installed via a 'gem'."
-       einfo "Previous versions used a standard tarball."
-       einfo "No packages in portage required ${PN}, so you won't be affected unless"
-       einfo "you have written ruby code which requires ${PN}. In that case you'll need"
-       einfo "to add this:"
-       einfo
-       einfo "require 'rubygems'"
-       einfo
-       einfo "before:"
-       einfo "require '${PN}'"
+       elog "NOTE: This package is now installed via a 'gem'."
+       elog "Previous versions used a standard tarball."
+       elog "No packages in portage required ${PN}, so you won't be affected unless"
+       elog "you have written ruby code which requires ${PN}. In that case you'll need"
+       elog "to add this:"
+       elog
+       elog "require 'rubygems'"
+       elog
+       elog "before:"
+       elog "require '${PN}'"
 }
 
index 6b054cb0bbae6dd9705e51d37b60169298c99037..ca6d38c4e53709032deca319a69a252b3337953d 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-ruby/rubytorrent
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubytorrent/ChangeLog,v 1.6 2006/10/20 21:29:58 agriffis Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubytorrent/ChangeLog,v 1.7 2007/01/05 16:51:31 flameeyes Exp $
+
+  05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> rubytorrent-0.3.ebuild:
+  Convert to use elog.
 
   20 Oct 2006; Aron Griffis <agriffis@gentoo.org> rubytorrent-0.3.ebuild:
   Mark 0.3 stable on ia64
index 7f2ef78101d16740a02733babe0f4c88bd9c5fb3..03706b8b473cab4703eb2330706572bb59182749 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubytorrent/rubytorrent-0.3.ebuild,v 1.6 2006/10/20 21:29:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubytorrent/rubytorrent-0.3.ebuild,v 1.7 2007/01/05 16:51:31 flameeyes Exp $
 
 inherit ruby
 
@@ -30,7 +30,7 @@ src_install() {
 }
 
 pkg_postinstall() {
-       einfo
-       einfo "Examples on how to use this package can be found at /usr/share/doc/${PF}/examples/"
-       einfo
+       elog
+       elog "Examples on how to use this package can be found at /usr/share/doc/${PF}/examples/"
+       elog
 }