dev-python/python-daap: Use append-cflags
authorJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:42:42 +0000 (18:42 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 16:53:45 +0000 (18:53 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/python-daap/python-daap-0.7.1-r1.ebuild

index 3fc3cbb84be2256741a83e59e1edd3e02097220a..660608e3483e5628c3510f5f678b3f187e94da21 100644 (file)
@@ -3,9 +3,10 @@
 # $Id$
 
 EAPI=5
+
 PYTHON_COMPAT=( python2_7 )
 
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
 
 MY_P="PythonDaap-${PV}"
 
@@ -18,12 +19,12 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="examples"
 
-DEPEND=""
-RDEPEND=""
-
 S="${WORKDIR}/${MY_P}"
 
-CFLAGS="${CFLAGS} -fno-strict-aliasing"
+python_prepare_all() {
+       distutils-r1_python_prepare_all
+       append-cflags -fno-strict-aliasing
+}
 
 python_install_all() {
        use examples && local EXAMPLES=( examples/. )