app-eselect/eselect-renpy: migrate from the games eclass
authorAndrew Savchenko <bircoph@gentoo.org>
Sun, 16 Jul 2017 17:48:08 +0000 (20:48 +0300)
committerAndrew Savchenko <bircoph@gentoo.org>
Sun, 16 Jul 2017 17:48:08 +0000 (20:48 +0300)
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
app-eselect/eselect-renpy/eselect-renpy-0.7.ebuild [new file with mode: 0644]
app-eselect/eselect-renpy/files/renpy.eselect-0.7 [new file with mode: 0644]

diff --git a/app-eselect/eselect-renpy/eselect-renpy-0.7.ebuild b/app-eselect/eselect-renpy/eselect-renpy-0.7.ebuild
new file mode 100644 (file)
index 0000000..4ee9286
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Manages renpy symlink"
+HOMEPAGE="https://www.gentoo.org/proj/en/eselect/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       app-eselect/eselect-lib-bin-symlink
+       !<games-engines/renpy-6.99.12-r2"
+
+S=${WORKDIR}
+
+pkg_setup() { :; }
+
+src_prepare() {
+       sed \
+               -e "s|@BINDIR@|${EROOT}usr/bin|" \
+               "${FILESDIR}"/renpy.eselect-${PV} > "${WORKDIR}"/renpy.eselect || die
+       eapply_user
+}
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+       insinto /usr/share/eselect/modules
+       doins renpy.eselect
+}
+
+pkg_preinst() { :; }
+
+pkg_postinst() { :; }
diff --git a/app-eselect/eselect-renpy/files/renpy.eselect-0.7 b/app-eselect/eselect-renpy/files/renpy.eselect-0.7
new file mode 100644 (file)
index 0000000..6719926
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Manage default renpy version"
+MAINTAINER="bircoph@gentoo.org"
+VERSION="0.7"
+
+SYMLINK_PATH="@BINDIR@/renpy"
+SYMLINK_TARGETS=( renpy-6.99 )
+SYMLINK_DESCRIPTION='default renpy'
+SYMLINK_CRUCIAL=1
+
+inherit bin-symlink
+