dev-util/clion: version bump to 2019.2.4
authorChristian Strahl <c.a.strahl@gmail.com>
Sun, 13 Oct 2019 12:46:47 +0000 (14:46 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 18 Oct 2019 05:25:34 +0000 (08:25 +0300)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Christian Strahl <c.a.strahl@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-util/clion/Manifest
dev-util/clion/clion-2019.2.4.ebuild [new file with mode: 0644]

index 884263a7b6c0fa8e20b9ccfc005bd447f2622b1f..877bc690892298d911f23fccb55ee50626e35aaf 100644 (file)
@@ -1 +1,2 @@
 DIST clion-2019.2.3.tar.gz 495323742 BLAKE2B b4747a4805ec7d8776e3c52c4f94a2d12c1156eff9c0a65e5e275bed269f472d3e8d410e2ef41b2e1504408cf7dfe3f2b8ccee06c5cdba4c8664ad5e7a1873fd SHA512 34599a92b9522cbc6bee6505a26d24b9d4ac727100b2b30414199ac3ec03f73d81c5811f66b35ad51e846eb6fcf66651c522207bb5f471adbf5c5e25d5e7d7d5
+DIST clion-2019.2.4.tar.gz 495317026 BLAKE2B 24e2dfbd9253b1b2bf70f8259ee09c6439d5623c12c78a7af60a9bdf00cdb48c7d2967150b5dca98c588b91573f2928288dbb57416b6fe397e3f7ea4b4d7bc23 SHA512 fbac7c3f6ea8b7f38031ad9a46dfd918683d66c317cca954d5f0f3b729040e23ac2ac1ea611bd6eff4c41ea3f03816ec95c4786475ab6f49dcf9b3d612d6c067
diff --git a/dev-util/clion/clion-2019.2.4.ebuild b/dev-util/clion/clion-2019.2.4.ebuild
new file mode 100644 (file)
index 0000000..fbe93d3
--- /dev/null
@@ -0,0 +1,80 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils
+
+DESCRIPTION="A complete toolset for C and C++ development"
+HOMEPAGE="https://www.jetbrains.com/clion"
+SRC_URI="https://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( IDEA IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )
+       Apache-1.1 Apache-2.0 BSD BSD-2 CC0-1.0 CDDL-1.1 CPL-0.5 CPL-1.0
+       EPL-1.0 EPL-2.0 GPL-2 GPL-2-with-classpath-exception GPL-3 ISC JDOM
+       LGPL-2.1+ LGPL-3 MIT MPL-1.0 MPL-1.1 OFL public-domain PSF-2 UoI-NCSA ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist mirror splitdebug"
+IUSE="custom-jdk"
+
+# RDEPENDS may cause false positives in repoman.
+# clion requires cmake and gdb at runtime to build and debug C/C++ projects
+RDEPEND="
+       dev-util/cmake
+       sys-devel/gdb
+       !custom-jdk? ( virtual/jdk )"
+
+QA_PREBUILT="opt/${P}/*"
+
+src_prepare() {
+       default
+
+       local remove_me=(
+               bin/gdb/linux
+               bin/lldb/linux
+               bin/cmake
+               license/CMake*
+               lib/pty4j-native/linux/ppc64le
+       )
+
+       use amd64 || remove_me+=( bin/fsnotifier64 lib/pty4j-native/linux/x86_64)
+       use arm || remove_me+=( bin/fsnotifier-arm )
+       use x86 || remove_me+=( bin/fsnotifier lib/pty4j-native/linux/x86)
+
+       use custom-jdk || remove_me+=( jbr )
+
+       rm -rv "${remove_me[@]}" || die
+}
+
+src_install() {
+       local dir="/opt/${P}"
+
+       insinto "${dir}"
+       doins -r *
+       fperms 755 "${dir}"/bin/{clion.sh,clang/linux/clang{d,-tidy}}
+
+       if use amd64; then
+               fperms 755 "${dir}"/bin/fsnotifier64
+       fi
+       if use arm; then
+               fperms 755 "${dir}"/bin/fsnotifier-arm
+       fi
+       if use x86; then
+               fperms 755 "${dir}"/bin/fsnotifier
+       fi
+
+       if use custom-jdk; then
+               if [[ -d jbr ]]; then
+               fperms 755 "${dir}"/jbr/bin/{jaotc,java,javac,jdb,jjs,jrunscript,keytool,pack200,rmid,rmiregistry,serialver,unpack200}
+               fi
+       fi
+
+       make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
+       newicon "bin/${PN}.svg" "${PN}.svg"
+       make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"
+
+       # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+       dodir /usr/lib/sysctl.d/
+       echo "fs.inotify.max_user_watches = 524288" > "${D}/usr/lib/sysctl.d/30-clion-inotify-watches.conf" || die
+}