net-analyzer/fping: Fix CFLAGS=-fno-common
authorJeroen Roovers <jer@gentoo.org>
Mon, 27 Jan 2020 00:39:11 +0000 (01:39 +0100)
committerJeroen Roovers <jer@gentoo.org>
Mon, 27 Jan 2020 00:39:25 +0000 (01:39 +0100)
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Closes: https://bugs.gentoo.org/show_bug.cgi?id=706528
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/fping/files/fping-4.2-fno-common.patch [new file with mode: 0644]
net-analyzer/fping/fping-4.2.ebuild

diff --git a/net-analyzer/fping/files/fping-4.2-fno-common.patch b/net-analyzer/fping/files/fping-4.2-fno-common.patch
new file mode 100644 (file)
index 0000000..d18af66
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/fping.h
++++ b/src/fping.h
+@@ -11,7 +11,7 @@
+ void crash_and_burn( char *message );
+ void errno_crash_and_burn( char *message );
+ int in_cksum( unsigned short *p, int n );
+-int random_data_flag;
++extern int random_data_flag;
+ /* socket.c */
+ int  open_ping_socket_ipv4();
index b181b90c670f919d8853c4cb4c3f3872c595cc28..fff3fa9ccd771d8d5ef8768671b0db26dce4c82c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -12,6 +12,10 @@ SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
 IUSE="ipv6 suid"
 
+PATCHES=(
+       "${FILESDIR}"/${PN}-4.2-fno-common.patch
+)
+
 src_configure() {
        econf $(use_enable ipv6)
 }