games-action/bomberclone: Build with gcc:5.2
authorTupone Alfredo <tupone@gentoo.org>
Thu, 17 Sep 2015 20:16:38 +0000 (22:16 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Fri, 18 Sep 2015 16:51:54 +0000 (18:51 +0200)
Package-Manager: portage-2.2.20.1

games-action/bomberclone/bomberclone-0.11.8.ebuild
games-action/bomberclone/files/bomberclone-0.11.8-gcc52.patch [new file with mode: 0644]

index 155c9d2cb052e66203aec70c78d1bad41b78c269..82e3062599433bb8a8d76887a6b2a257fb1a4d0c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -22,7 +22,8 @@ RDEPEND="${DEPEND}"
 
 src_prepare() {
        ecvs_clean
-       epatch "${FILESDIR}"/${P}-underlink.patch
+       epatch "${FILESDIR}"/${P}-underlink.patch \
+               "${FILESDIR}"/${P}-gcc52.patch
        eautoreconf
 }
 
diff --git a/games-action/bomberclone/files/bomberclone-0.11.8-gcc52.patch b/games-action/bomberclone/files/bomberclone-0.11.8-gcc52.patch
new file mode 100644 (file)
index 0000000..51fdaee
--- /dev/null
@@ -0,0 +1,11 @@
+--- src/single.c.old   2015-09-17 09:21:57.826930680 +0200
++++ src/single.c       2015-09-17 09:22:04.315824372 +0200
+@@ -476,7 +476,7 @@
+ };
+-inline int
++static inline int
+ ai_checknewpos (_point pos, int d)
+ {
+     _point m;