dev-ros/amcl: Bump to 1.16.2.
authorAlexis Ballier <aballier@gentoo.org>
Sat, 4 Aug 2018 18:36:09 +0000 (20:36 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 4 Aug 2018 18:46:32 +0000 (20:46 +0200)
Package-Manager: Portage-2.3.44, Repoman-2.3.10

dev-ros/amcl/Manifest
dev-ros/amcl/amcl-1.16.2.ebuild [new file with mode: 0644]

index 2e0595a1965d4d8c07bd5078ba76eedaade35c2f..67d0b9c053daa3a4e5265bb7abf97c46819a8962 100644 (file)
@@ -1 +1,2 @@
 DIST navigation-1.16.1.tar.gz 336908 BLAKE2B 0f22db60352a0f50938ae18104ecad72c2e06eedeb2da8f6afe09bdc346868fcd71c90b0243c366b9fd0e7a26fef7551ab6a4febe87ab8d66af5ce3497c68770 SHA512 f6742f5afcaff2d1fc699e2695845b148bb16523e301f79577a8073fcc829541158b7c463f2e5bd9f69571f8b4042dbfacfe563de54b16193b5a31721c5f6faf
+DIST navigation-1.16.2.tar.gz 337389 BLAKE2B a21d014df02ebf8046245777bb42fe3bccaf65af4c607532c4fb72e0b2c43870d1ff1c32c882a0418363708c0fa0c74925943beca2110a5f19b77a65e0a871fc SHA512 890eb391a8a70b3b17aa870dfa79bf48199cf3dcf7a8703b0e005b22ffd404edf723d73e30a04f902f436899fe321894bf3da7610f374b1a95b247629f64256e
diff --git a/dev-ros/amcl/amcl-1.16.2.ebuild b/dev-ros/amcl/amcl-1.16.2.ebuild
new file mode 100644 (file)
index 0000000..2c99003
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Probabilistic localization system for a robot moving in 2D"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/message_filters
+       dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/rosbag
+               dev-libs/boost:=
+       dev-ros/roscpp
+       dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/tf2
+       dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/tf2_ros
+"
+DEPEND="${RDEPEND}
+       test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/python_orocos_kdl[${PYTHON_USEDEP}] dev-ros/map_server[${PYTHON_USEDEP}] )
+"