app-arch/lha: EAPI7 revbump, use HTTPs
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Sun, 30 Sep 2018 11:54:37 +0000 (13:54 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 6 Oct 2018 22:33:10 +0000 (00:33 +0200)
Closes: https://bugs.gentoo.org/667360
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/10023

app-arch/lha/files/lha-114i-file-list-from-stdin.patch
app-arch/lha/files/lha-114i-fix-getopt_long-declaration.patch
app-arch/lha/lha-114i-r9.ebuild [new file with mode: 0644]

index 4bd0d17d75276ea4254e5400cc7679a097e657fd..d29f8d20bc8da92282fe1651ae703cd65ad7d59c 100644 (file)
@@ -1,7 +1,7 @@
 Index: src/lharc.c
 ===================================================================
---- src/lharc.c        (revision 773)
-+++ src/lharc.c        (working copy)
+--- a/src/lharc.c      (revision 773)
++++ b/src/lharc.c      (working copy)
 @@ -561,7 +561,7 @@
          if (!isatty(1) && cmd == CMD_ADD)
              quiet = TRUE;
@@ -13,8 +13,8 @@ Index: src/lharc.c
              /* Bug(?) on MinGW, isatty() return 0 on Cygwin console.
 Index: configure.ac
 ===================================================================
---- configure.ac       (revision 773)
-+++ configure.ac       (working copy)
+--- a/configure.ac     (revision 773)
++++ b/configure.ac     (working copy)
 @@ -289,6 +289,11 @@
            [Define to 1 if you want to ignore dot files with -X command line switch])
  fi
index b57a1c9c6158a66b7fd77e8eb7e504e9106a87c6..3c3b7dfd94c51c74b42f3ccc38c40be542897806 100644 (file)
@@ -1,5 +1,5 @@
---- src/getopt_long.c.orig      2013-12-18 16:05:59.789413528 -0600
-+++ src/getopt_long.c   2013-12-18 16:06:01.200420472 -0600
+--- a/src/getopt_long.c   2013-12-18 16:05:59.789413528 -0600
++++ b/src/getopt_long.c   2013-12-18 16:06:01.200420472 -0600
 @@ -64,7 +64,7 @@
  
  #ifndef USE_GNU
diff --git a/app-arch/lha/lha-114i-r9.ebuild b/app-arch/lha/lha-114i-r9.ebuild
new file mode 100644 (file)
index 0000000..fc3cd93
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+MY_P="${PN}-1.14i-ac20050924p1"
+
+DESCRIPTION="Utility for creating and opening lzh archives"
+HOMEPAGE="https://lha.osdn.jp https://github.com/jca02266/lha"
+SRC_URI="mirror://sourceforge.jp/${PN}/22231/${MY_P}.tar.gz"
+
+LICENSE="lha"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~m68k-mint"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-file-list-from-stdin.patch
+       "${FILESDIR}"/${P}-fix-getopt_long-declaration.patch
+)
+
+src_prepare() {
+       default
+
+       sed -e '/^AM_C_PROTOTYPES/d' \
+               -e 's/^AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' \
+               -i configure.ac || die #423125, 467544
+
+       eautoreconf
+}
+
+src_configure() {
+       append-cppflags -DPROTOTYPES #423125
+
+       if [[ ${CHOST} == *-interix* ]]; then
+               export ac_cv_header_inttypes_h=no
+               export ac_cv_func_iconv=no
+       fi
+
+       econf
+}
+
+src_install() {
+       emake \
+               DESTDIR="${D}" \
+               mandir="${EPREFIX}"/usr/share/man/ja \
+               install
+
+       dodoc ChangeLog Hacking_of_LHa
+}