Index: src/lharc.c
===================================================================
---- src/lharc.c (revision 773)
-+++ src/lharc.c (working copy)
+--- a/src/lharc.c (revision 773)
++++ b/src/lharc.c (working copy)
@@ -561,7 +561,7 @@
if (!isatty(1) && cmd == CMD_ADD)
quiet = TRUE;
/* Bug(?) on MinGW, isatty() return 0 on Cygwin console.
Index: configure.ac
===================================================================
---- configure.ac (revision 773)
-+++ configure.ac (working copy)
+--- a/configure.ac (revision 773)
++++ b/configure.ac (working copy)
@@ -289,6 +289,11 @@
[Define to 1 if you want to ignore dot files with -X command line switch])
fi
---- src/getopt_long.c.orig 2013-12-18 16:05:59.789413528 -0600
-+++ src/getopt_long.c 2013-12-18 16:06:01.200420472 -0600
+--- a/src/getopt_long.c 2013-12-18 16:05:59.789413528 -0600
++++ b/src/getopt_long.c 2013-12-18 16:06:01.200420472 -0600
@@ -64,7 +64,7 @@
#ifndef USE_GNU
--- /dev/null
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+MY_P="${PN}-1.14i-ac20050924p1"
+
+DESCRIPTION="Utility for creating and opening lzh archives"
+HOMEPAGE="https://lha.osdn.jp https://github.com/jca02266/lha"
+SRC_URI="mirror://sourceforge.jp/${PN}/22231/${MY_P}.tar.gz"
+
+LICENSE="lha"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~m68k-mint"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-file-list-from-stdin.patch
+ "${FILESDIR}"/${P}-fix-getopt_long-declaration.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e '/^AM_C_PROTOTYPES/d' \
+ -e 's/^AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' \
+ -i configure.ac || die #423125, 467544
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -DPROTOTYPES #423125
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ export ac_cv_header_inttypes_h=no
+ export ac_cv_func_iconv=no
+ fi
+
+ econf
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ mandir="${EPREFIX}"/usr/share/man/ja \
+ install
+
+ dodoc ChangeLog Hacking_of_LHa
+}