dev-python/oslo-utils: 4.1.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 16 May 2020 20:43:02 +0000 (15:43 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 16 May 2020 21:21:18 +0000 (16:21 -0500)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/oslo-utils/Manifest
dev-python/oslo-utils/oslo-utils-4.1.1.ebuild [new file with mode: 0644]

index e387bbf48078eefaa3bbd6716dca82620ac605a5..1378f359be3f846e632c9d86cc0460e017c44ab0 100644 (file)
@@ -1 +1,2 @@
 DIST oslo-utils-3.41.5.tar.gz 91662 BLAKE2B 28ab74823b68cdf427396e5e357f567be5540eaf28e56416015d41ba76ddbe0970064b672c46b53bf23c2dfaae442462fa89d1e140e5f5a271db6e72e4b3e615 SHA512 0d9f9a99a48c0d6623947df6557eca24ebb2ae21d110e1c2a37e09c89fc2749d3ae480bfb534b3a2e3a6f9e7b0db126497f3403825b1272a30f532aa57795b04
+DIST oslo-utils-4.1.1.tar.gz 92838 BLAKE2B f468f77bc72124c404d4aac2b8ca9fd7f05140e45bfcc9b19e04e5d3181532fd82f941b7a00d22f1cb656ae46dc205e7da449772666a8892b8d7ea6469bb6505 SHA512 d6388af59caa7531901eb5585e1dd9eca544dd722bb4cdafb19221c33c543508306415f504b27559366eec2a9c7102acb181d8b833ee038e46e90567208daefd
diff --git a/dev-python/oslo-utils/oslo-utils-4.1.1.ebuild b/dev-python/oslo-utils/oslo-utils-4.1.1.ebuild
new file mode 100644 (file)
index 0000000..eed1c4c
--- /dev/null
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Utility library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       test? (
+               >=dev-python/eventlet-0.18.2[${PYTHON_USEDEP}]
+               !~dev-python/eventlet-0.18.3[${PYTHON_USEDEP}]
+               !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+               !~dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+               !~dev-python/eventlet-0.23.0[${PYTHON_USEDEP}]
+               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+               >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+               >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+               >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+               >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+               >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/coverage-4.0.0[${PYTHON_USEDEP}]
+               !~dev-python/coverage-4.4.0[${PYTHON_USEDEP}]
+               >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+               >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+               <dev-python/bandit-1.6.0[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+       >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+       >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+       >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
+       >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+       >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}
+
+# Note: Tests fail due to requiring installation
+#
+# Installation appears to fail due to the use of namespace packages but root
+# cause was never truly established.
+#
+# Tests fail with:
+# ImportError: No module named 'oslo.utils
+
+#RESTRICT="test"
+
+python_test() {
+       distutils_install_for_testing
+
+       cd "${TEST_DIR}"/lib || die
+
+       rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+       testr init || die "testr init failed under ${EPYTHON}"
+       testr run || die "testr run failed under ${EPYTHON}"
+}