dev-ros/opencv_tests: Fix broken deps on opencv.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 13:14:09 +0000 (15:14 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 13:14:09 +0000 (15:14 +0200)
Package-Manager: portage-2.2.21

dev-ros/opencv_tests/opencv_tests-1.11.8.ebuild
dev-ros/opencv_tests/opencv_tests-9999.ebuild

index 9c9cf256119a196394bae59e2718c97ba8b07727..770ea0be049c35c90df4e8f784a61ce5c59a3072 100644 (file)
@@ -5,6 +5,7 @@
 EAPI=5
 ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
 KEYWORDS="~amd64 ~arm"
+# Be careful: It needs opencv with python support but opencv is python-single-r1
 PYTHON_COMPAT=( python2_7 )
 ROS_SUBDIR=${PN}
 
@@ -18,7 +19,7 @@ IUSE=""
 RDEPEND="
        dev-ros/cv_bridge[${PYTHON_USEDEP}]
        dev-ros/rospy[${PYTHON_USEDEP}]
-       media-libs/opencv[python,${PYTHON_USEDEP}]
+       media-libs/opencv[python,python_single_target_python2_7]
        dev-python/numpy[${PYTHON_USEDEP}]
 "
 DEPEND="${RDEPEND}"
index 9c9cf256119a196394bae59e2718c97ba8b07727..770ea0be049c35c90df4e8f784a61ce5c59a3072 100644 (file)
@@ -5,6 +5,7 @@
 EAPI=5
 ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
 KEYWORDS="~amd64 ~arm"
+# Be careful: It needs opencv with python support but opencv is python-single-r1
 PYTHON_COMPAT=( python2_7 )
 ROS_SUBDIR=${PN}
 
@@ -18,7 +19,7 @@ IUSE=""
 RDEPEND="
        dev-ros/cv_bridge[${PYTHON_USEDEP}]
        dev-ros/rospy[${PYTHON_USEDEP}]
-       media-libs/opencv[python,${PYTHON_USEDEP}]
+       media-libs/opencv[python,python_single_target_python2_7]
        dev-python/numpy[${PYTHON_USEDEP}]
 "
 DEPEND="${RDEPEND}"