dev-libs/boost: Version bump to 1.70.0
authorDavid Seifert <soap@gentoo.org>
Sun, 14 Apr 2019 23:40:42 +0000 (01:40 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 14 Apr 2019 23:40:42 +0000 (01:40 +0200)
* bzip2/lzma/zlib/zstd support can now be
  disabled via USE flags explicitly.
* Upstream has fixed Boost.Python to finally
  support building against multiple Python 3
  implementations concurrently:

    https://github.com/boostorg/python/commit/d4d41d94aecc

  Going forward, Gentoo will stop modifying
  the upstream build system for its multiple
  implementations. This will lead to some
  short-term pain, as the library pattern changes
  from

    libboost_python-3.6.so

  to

    libboost_python36.so

  which is the canonical name used by upstream.
  Changing this name should be avoided, as the
  filename is also encoded as a macro in various
  boost headers.

Bug: https://bugs.gentoo.org/631590
Closes: https://bugs.gentoo.org/653878
Closes: https://github.com/gentoo/gentoo/pull/11659
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: David Seifert <soap@gentoo.org>
dev-libs/boost/Manifest
dev-libs/boost/boost-1.70.0.ebuild [new file with mode: 0644]
dev-libs/boost/files/boost-1.69.0-context-x32.patch [new file with mode: 0644]
dev-libs/boost/files/boost-1.70.0-fix-python-cmake-duplicate-target.patch [new file with mode: 0644]
dev-libs/boost/metadata.xml
dev-util/boost-build/Manifest
dev-util/boost-build/boost-build-1.70.0.ebuild [new file with mode: 0644]
profiles/arch/amd64-fbsd/package.use.mask
profiles/package.mask

index 19a425758e8616c9e358d346f6ba4a41cab27a88..2b2ef1bcd319d983b08780c78a8a759e1fdf1152 100644 (file)
@@ -2,3 +2,4 @@ DIST boost_1_63_0.tar.bz2 81984414 BLAKE2B 227c4432bd3ca0eb390048ec85047958fcb6a
 DIST boost_1_65_0.tar.bz2 82597718 BLAKE2B 0080956d6ad2f14130ce4a4734b1bd1ce83d3651b226653689e02770baa83cf11811ef4e44948ff68a168d9ce5cbfaea4f758970df2b4e9faa2d410181885f5b SHA512 7142650fb8d61e3ef16ba066fc918e087f19e9bc2ad1d6a11fb10bf0d6b1b5ad05ab032f076a5233a1624b3669e952b2cc38b7dc074bbf53018e2970ee90fcdd
 DIST boost_1_66_0.tar.bz2 85995778 BLAKE2B 9ab1fe396b10ab85d7e4084ec7abb8d785ecd892c8f51aea5a401cb565b111c256533364fe028da74ed376534889f43c5ccbdcd703cd236526ae66a064220765 SHA512 0f34075d35391d66876e5189a01a11880a79428e1b267456348ee148dba9dc3abdc74d568f1853be631d20b584b1c804b42443c266f7622164acfc10be3dab8b
 DIST boost_1_67_0.tar.bz2 87336566 BLAKE2B 85ea00fc2197b1bbfc35d69427c87f23ea43d7592f1c9ce66e2afcde8476bdec86f6debdac815b23de59f4665a8e0c7f1519ab66a31d39df629723bc45710058 SHA512 82bf33d7d2c3db109c9d1f12d40bc2d364c8c95262386f906ccd1a71cd71433bcc01829e968b4a13a5003cf0b50cbdf0b435a1d76530cea7bb05725c327411e8
+DIST boost_1_70_0.tar.bz2 97887058 BLAKE2B dc7a974c6dc2662b767dbd87cb832cd1749c24fb745779d1059b73f19f7e52b33b645adfe72b0296c5e098e5cdb3b9f5eddd382374f33fbcd2ad5739287b2206 SHA512 7f2ea9636baf0210e8ed1d21ee798efb6ce23c0710ff8228b285e2214f82193bcd2d912fd435929c554289a59101c7be2e27ce798f93833f307976f0dd070b49
diff --git a/dev-libs/boost/boost-1.70.0.ebuild b/dev-libs/boost/boost-1.70.0.ebuild
new file mode 100644 (file)
index 0000000..6d40a9f
--- /dev/null
@@ -0,0 +1,327 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit flag-o-matic multiprocessing python-r1 toolchain-funcs multilib-minimal
+
+MY_P="${PN}_$(ver_rs 1- _)"
+MAJOR_V="$(ver_cut 1-2)"
+
+DESCRIPTION="Boost Libraries for C++"
+HOMEPAGE="https://www.boost.org/"
+SRC_URI="https://downloads.sourceforge.net/project/boost/${PN}/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0/${PV}" # ${PV} instead ${MAJOR_V} due to bug 486122
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris ~x86-winnt"
+IUSE="bzip2 context debug doc icu lzma +nls mpi numpy python static-libs +threads tools zlib zstd"
+REQUIRED_USE="
+       mpi? ( threads )
+       python? ( ${PYTHON_REQUIRED_USE} )"
+
+# the tests will never fail because these are not intended as sanity
+# tests at all. They are more a way for upstream to check their own code
+# on new compilers. Since they would either be completely unreliable
+# (failing for no good reason) or completely useless (never failing)
+# there is no point in having them in the ebuild to begin with.
+RESTRICT="test"
+
+RDEPEND="
+       !app-admin/eselect-boost
+       bzip2? ( app-arch/bzip2:=[${MULTILIB_USEDEP}] )
+       icu? ( >=dev-libs/icu-3.6:=[${MULTILIB_USEDEP}] )
+       !icu? ( virtual/libiconv[${MULTILIB_USEDEP}] )
+       lzma? ( app-arch/xz-utils:=[${MULTILIB_USEDEP}] )
+       mpi? ( >=virtual/mpi-2.0-r4[${MULTILIB_USEDEP},cxx,threads] )
+       python? (
+               ${PYTHON_DEPS}
+               numpy? ( >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}] )
+       )
+       zlib? ( sys-libs/zlib:=[${MULTILIB_USEDEP}] )
+       zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+       =dev-util/boost-build-${MAJOR_V}*"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.48.0-disable_icu_rpath.patch
+       "${FILESDIR}"/${PN}-1.69.0-context-x32.patch
+       "${FILESDIR}"/${PN}-1.56.0-build-auto_index-tool.patch
+       "${FILESDIR}"/${PN}-1.70.0-fix-python-cmake-duplicate-target.patch
+)
+
+python_bindings_needed() {
+       multilib_is_native_abi && use python
+}
+
+tools_needed() {
+       multilib_is_native_abi && use tools
+}
+
+create_user-config.jam() {
+       local user_config_jam="${BUILD_DIR}"/user-config.jam
+       if [[ -s ${user_config_jam} ]]; then
+               einfo "${user_config_jam} already exists, skipping configuration"
+               return
+       else
+               einfo "Creating configuration in ${user_config_jam}"
+       fi
+
+       local compiler compiler_version compiler_executable="$(tc-getCXX)"
+       if [[ ${CHOST} == *-darwin* ]]; then
+               compiler="darwin"
+               compiler_version="$(gcc-fullversion)"
+       else
+               compiler="gcc"
+               compiler_version="$(gcc-version)"
+       fi
+
+       if use mpi; then
+               local mpi_configuration="using mpi ;"
+       fi
+
+       cat > "${user_config_jam}" <<- __EOF__ || die
+               using ${compiler} : ${compiler_version} : ${compiler_executable} : <cflags>"${CFLAGS}" <cxxflags>"${CXXFLAGS}" <linkflags>"${LDFLAGS}" ;
+               ${mpi_configuration}
+       __EOF__
+
+       if python_bindings_needed; then
+               append_to_user_config() {
+                       local py_config
+                       if tc-is-cross-compiler; then
+                               py_config="using python : ${EPYTHON#python} : : ${ESYSROOT}/usr/include/${EPYTHON} : ${ESYSROOT}/usr/$(get_libdir) ;"
+                       else
+                               py_config="using python : ${EPYTHON#python} : ${PYTHON} : $(python_get_includedir) ;"
+                       fi
+                       echo "${py_config}" >> "${user_config_jam}" || die
+               }
+               python_foreach_impl append_to_user_config
+       fi
+
+       if python_bindings_needed && use numpy; then
+               einfo "Enabling support for NumPy extensions in Boost.Python"
+       else
+               einfo "Disabling support for NumPy extensions in Boost.Python"
+
+               # Boost.Build does not allow for disabling of numpy
+               # extensions, thereby leading to automagic numpy
+               # https://github.com/boostorg/python/issues/111#issuecomment-280447482
+               sed \
+                       -e 's/\[ unless \[ python\.numpy \] : <build>no \]/<build>no/g' \
+                       -i "${BUILD_DIR}"/libs/python/build/Jamfile || die
+       fi
+}
+
+pkg_setup() {
+       # Bail out on unsupported build configuration, bug #456792
+       if [[ -f "${EROOT}/etc/site-config.jam" ]]; then
+               if ! grep -q 'gentoo\(debug\|release\)' "${EROOT}/etc/site-config.jam"; then
+                       eerror "You are using custom ${EROOT}/etc/site-config.jam without defined gentoorelease/gentoodebug targets."
+                       eerror "Boost can not be built in such configuration."
+                       eerror "Please, either remove this file or add targets from ${EROOT}/usr/share/boost-build/site-config.jam to it."
+                       die "Unsupported target in ${EROOT}/etc/site-config.jam"
+               fi
+       fi
+}
+
+src_prepare() {
+       default
+
+       # Do not try to build missing 'wave' tool, bug #522682
+       # Upstream bugreport - https://svn.boost.org/trac/boost/ticket/10507
+       sed -i -e 's:wave/build//wave::' tools/Jamfile.v2 || die
+
+       multilib_copy_sources
+}
+
+ejam() {
+       create_user-config.jam
+
+       local b2_opts=( "--user-config=${BUILD_DIR}/user-config.jam" )
+       if python_bindings_needed; then
+               append_to_b2_opts() {
+                       b2_opts+=( python="${EPYTHON#python}" )
+               }
+               python_foreach_impl append_to_b2_opts
+       else
+               b2_opts+=( --without-python )
+       fi
+       b2_opts+=( "$@" )
+
+       echo b2 "${b2_opts[@]}" >&2
+       b2 "${b2_opts[@]}"
+}
+
+src_configure() {
+       # Workaround for too many parallel processes requested, bug #506064
+       [[ "$(makeopts_jobs)" -gt 64 ]] && MAKEOPTS="${MAKEOPTS} -j64"
+
+       OPTIONS=(
+               $(usex debug gentoodebug gentoorelease)
+               "-j$(makeopts_jobs)"
+               -q
+               -d+2
+               pch=off
+               $(usex icu "-sICU_PATH=${EPREFIX}/usr" '--disable-icu boost.locale.icu=off')
+               $(usex mpi '' '--without-mpi')
+               $(usex nls '' '--without-locale')
+               $(usex context '' '--without-context --without-coroutine --without-fiber')
+               $(usex threads '' '--without-thread')
+               --boost-build="${EPREFIX}"/usr/share/boost-build
+               --prefix="${ED}/usr"
+               --layout=system
+               # building with threading=single is currently not possible
+               # https://svn.boost.org/trac/boost/ticket/7105
+               threading=multi
+               link=$(usex static-libs shared,static shared)
+               # this seems to be the only way to disable compression algorithms
+               # https://www.boost.org/doc/libs/1_70_0/libs/iostreams/doc/installation.html#boost-build
+               -sNO_BZIP2=$(usex bzip2 0 1)
+               -sNO_LZMA=$(usex lzma 0 1)
+               -sNO_ZLIB=$(usex zlib 0 1)
+               -sNO_ZSTD=$(usex zstd 0 1)
+       )
+
+       if [[ ${CHOST} == *-darwin* ]]; then
+               # We need to add the prefix, and in two cases this exceeds, so prepare
+               # for the largest possible space allocation.
+               append-ldflags -Wl,-headerpad_max_install_names
+       fi
+
+       # bug 298489
+       if use ppc || use ppc64; then
+               [[ $(gcc-version) > 4.3 ]] && append-flags -mno-altivec
+       fi
+
+       # Use C++14 globally as of 1.62
+       append-cxxflags -std=c++14
+}
+
+multilib_src_compile() {
+       ejam "${OPTIONS[@]}" || die
+
+       if tools_needed; then
+               pushd tools >/dev/null || die
+               ejam \
+                       "${OPTIONS[@]}" \
+                       || die "Building of Boost tools failed"
+               popd >/dev/null || die
+       fi
+}
+
+multilib_src_install_all() {
+       if ! use numpy; then
+               rm -r "${ED}"/usr/include/boost/python/numpy* || die
+       fi
+
+       if ! use python; then
+               rm -r "${ED}"/usr/include/boost/{python*,mpi/python*,parameter/aux_/python,parameter/python*} || die
+       fi
+
+       if ! use nls; then
+               rm -r "${ED}"/usr/include/boost/locale || die
+       fi
+
+       if ! use context; then
+               rm -r "${ED}"/usr/include/boost/context || die
+               rm -r "${ED}"/usr/include/boost/coroutine{,2} || die
+               rm "${ED}"/usr/include/boost/asio/spawn.hpp || die
+       fi
+
+       if use doc; then
+               # find extraneous files that shouldn't be installed
+               # as part of the documentation and remove them.
+               find libs/*/* \( -iname 'test' -o -iname 'src' \) -exec rm -rf '{}' + || die
+               find doc \( -name 'Jamfile.v2' -o -name 'build' -o -name '*.manifest' \) -exec rm -rf '{}' + || die
+               find tools \( -name 'Jamfile.v2' -o -name 'src' -o -name '*.cpp' -o -name '*.hpp' \) -exec rm -rf '{}' + || die
+
+               docinto html
+               dodoc *.{htm,html,png,css}
+               dodoc -r doc libs more tools
+
+               # To avoid broken links
+               dodoc LICENSE_1_0.txt
+
+               dosym ../../../../include/boost /usr/share/doc/${PF}/html/boost
+       fi
+}
+
+multilib_src_install() {
+       ejam \
+               "${OPTIONS[@]}" \
+               --includedir="${ED}/usr/include" \
+               --libdir="${ED}/usr/$(get_libdir)" \
+               install || die "Installation of Boost libraries failed"
+
+       pushd "${ED}/usr/$(get_libdir)" >/dev/null || die
+
+       local ext=$(get_libname)
+       if use threads; then
+               local f
+               for f in *${ext}; do
+                       dosym ${f} /usr/$(get_libdir)/${f/${ext}/-mt${ext}}
+               done
+       fi
+
+       popd >/dev/null || die
+
+       if tools_needed; then
+               dobin dist/bin/*
+
+               insinto /usr/share
+               doins -r dist/share/boostbook
+       fi
+
+       # boost's build system truely sucks for not having a destdir.  Because for
+       # this reason we are forced to build with a prefix that includes the
+       # DESTROOT, dynamic libraries on Darwin end messed up, referencing the
+       # DESTROOT instread of the actual EPREFIX.  There is no way out of here
+       # but to do it the dirty way of manually setting the right install_names.
+       if [[ ${CHOST} == *-darwin* ]]; then
+               einfo "Working around completely broken build-system(tm)"
+               local d
+               for d in "${ED}"/usr/lib/*.dylib; do
+                       if [[ -f ${d} ]]; then
+                               # fix the "soname"
+                               ebegin "  correcting install_name of ${d#${ED}}"
+                               install_name_tool -id "/${d#${D}}" "${d}"
+                               eend $?
+                               # fix references to other libs
+                               refs=$(otool -XL "${d}" | \
+                                       sed -e '1d' -e 's/^\t//' | \
+                                       grep "^libboost_" | \
+                                       cut -f1 -d' ')
+                               local r
+                               for r in ${refs}; do
+                                       ebegin "    correcting reference to ${r}"
+                                       install_name_tool -change \
+                                               "${r}" \
+                                               "${EPREFIX}/usr/lib/${r}" \
+                                               "${d}"
+                                       eend $?
+                               done
+                       fi
+               done
+       fi
+}
+
+pkg_preinst() {
+       # Yai for having symlinks that are nigh-impossible to remove without
+       # resorting to dirty hacks like these. Removes lingering symlinks
+       # from the slotted versions.
+       local symlink
+       for symlink in "${EROOT}/usr/include/boost" "${EROOT}/usr/share/boostbook"; do
+               if [[ -L ${symlink} ]]; then
+                       rm -f "${symlink}" || die
+               fi
+       done
+
+       # some ancient installs still have boost cruft lying around
+       # for unknown reasons, causing havoc for reverse dependencies
+       # Bug: 607734
+       rm -rf "${EROOT}"/usr/include/boost-1_[3-5]? || die
+}
diff --git a/dev-libs/boost/files/boost-1.69.0-context-x32.patch b/dev-libs/boost/files/boost-1.69.0-context-x32.patch
new file mode 100644 (file)
index 0000000..9ee3d54
--- /dev/null
@@ -0,0 +1,38 @@
+--- a/libs/context/src/asm/jump_i386_sysv_elf_gas.S
++++ b/libs/context/src/asm/jump_i386_sysv_elf_gas.S
+@@ -24,6 +24,10 @@
+  *                                                                                      *
+  ****************************************************************************************/
++#ifdef __x86_64__
++#include "jump_x86_64_sysv_elf_gas.S"
++#else
++
+ .file "jump_i386_sysv_elf_gas.S"
+ .text
+ .globl jump_fcontext
+@@ -81,3 +85,5 @@
+ /* Mark that we don't need executable stack.  */
+ .section .note.GNU-stack,"",%progbits
++
++#endif
+--- a/libs/context/src/asm/make_i386_sysv_elf_gas.S
++++ b/libs/context/src/asm/make_i386_sysv_elf_gas.S
+@@ -24,6 +24,10 @@
+  *                                                                                      *
+  ****************************************************************************************/
++#ifdef __x86_64__
++#include "make_x86_64_sysv_elf_gas.S"
++#else
++
+ .file "make_i386_sysv_elf_gas.S"
+ .text
+ .globl make_fcontext
+@@ -105,3 +109,5 @@
+ /* Mark that we don't need executable stack.  */
+ .section .note.GNU-stack,"",%progbits
++
++#endif
diff --git a/dev-libs/boost/files/boost-1.70.0-fix-python-cmake-duplicate-target.patch b/dev-libs/boost/files/boost-1.70.0-fix-python-cmake-duplicate-target.patch
new file mode 100644 (file)
index 0000000..c0097a8
--- /dev/null
@@ -0,0 +1,33 @@
+Boost.Build errors out when passing multiple python impls to b2:
+
+    error: Name clash for '<p/var/tmp/portage/dev-libs/boost-1.70.0/image/usr/lib64/cmake/boost_python-1.70.0>libboost_python-variant-shared.cmake'
+    error:
+    error: Tried to build the target twice, with property sets having
+    error: these incompatible properties:
+    error:
+    error:     -  <python>2.7
+    error:     -  <python>3.6
+    error:
+    error: Please make sure to have consistent requirements for these
+    error: properties everywhere in your project, especially for install
+    error: targets.
+
+https://github.com/boostorg/python/issues/262
+
+--- a/tools/boost_install/boost-install.jam
++++ b/tools/boost_install/boost-install.jam
+@@ -870,12 +870,12 @@
+     $(p).mark-target-as-explicit install-libraries ;
+-    install-cmake-config $(libraries) ;
++    # install-cmake-config $(libraries) ;
+     generate install-dependencies : $(libraries) : <generating-rule>@boost-install%generate-dependencies <name>install ;
+     $(p).mark-target-as-explicit install-dependencies ;
+-    alias install : install-libraries install-cmake-config install-dependencies ;
++    alias install : install-libraries install-dependencies ;
+     $(p).mark-target-as-explicit install ;
+     # Target stage
index 4f85afb6e3f1e3d02aac555abf041410b47c2d37..aa525f6bd815c85606f8dc28b3285233b084618a 100644 (file)
@@ -17,6 +17,8 @@
                <flag name="threads">Build multi-thread-compatible libraries instead of single-threaded only.</flag>
                <flag name="nls">Build libboost_locale. This library requires compatible C library interfaces, which might not be provided by uClibc or other embedded libraries.</flag>
                <flag name="doc">Install the full API documentation documentation. This takes over 200MB of extra disk space.</flag>
+               <flag name="numpy">Optionally build NumPy extensions when Boost.Python is enabled</flag>
+               <flag name="zstd">Enable zstd compression support in Boost.Iostreams</flag>
        </use>
        <upstream>
                <remote-id type="sourceforge">boost</remote-id>
index 19a425758e8616c9e358d346f6ba4a41cab27a88..2b2ef1bcd319d983b08780c78a8a759e1fdf1152 100644 (file)
@@ -2,3 +2,4 @@ DIST boost_1_63_0.tar.bz2 81984414 BLAKE2B 227c4432bd3ca0eb390048ec85047958fcb6a
 DIST boost_1_65_0.tar.bz2 82597718 BLAKE2B 0080956d6ad2f14130ce4a4734b1bd1ce83d3651b226653689e02770baa83cf11811ef4e44948ff68a168d9ce5cbfaea4f758970df2b4e9faa2d410181885f5b SHA512 7142650fb8d61e3ef16ba066fc918e087f19e9bc2ad1d6a11fb10bf0d6b1b5ad05ab032f076a5233a1624b3669e952b2cc38b7dc074bbf53018e2970ee90fcdd
 DIST boost_1_66_0.tar.bz2 85995778 BLAKE2B 9ab1fe396b10ab85d7e4084ec7abb8d785ecd892c8f51aea5a401cb565b111c256533364fe028da74ed376534889f43c5ccbdcd703cd236526ae66a064220765 SHA512 0f34075d35391d66876e5189a01a11880a79428e1b267456348ee148dba9dc3abdc74d568f1853be631d20b584b1c804b42443c266f7622164acfc10be3dab8b
 DIST boost_1_67_0.tar.bz2 87336566 BLAKE2B 85ea00fc2197b1bbfc35d69427c87f23ea43d7592f1c9ce66e2afcde8476bdec86f6debdac815b23de59f4665a8e0c7f1519ab66a31d39df629723bc45710058 SHA512 82bf33d7d2c3db109c9d1f12d40bc2d364c8c95262386f906ccd1a71cd71433bcc01829e968b4a13a5003cf0b50cbdf0b435a1d76530cea7bb05725c327411e8
+DIST boost_1_70_0.tar.bz2 97887058 BLAKE2B dc7a974c6dc2662b767dbd87cb832cd1749c24fb745779d1059b73f19f7e52b33b645adfe72b0296c5e098e5cdb3b9f5eddd382374f33fbcd2ad5739287b2206 SHA512 7f2ea9636baf0210e8ed1d21ee798efb6ce23c0710ff8228b285e2214f82193bcd2d912fd435929c554289a59101c7be2e27ce798f93833f307976f0dd070b49
diff --git a/dev-util/boost-build/boost-build-1.70.0.ebuild b/dev-util/boost-build/boost-build-1.70.0.ebuild
new file mode 100644 (file)
index 0000000..98eb1a3
--- /dev/null
@@ -0,0 +1,142 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit flag-o-matic python-single-r1 toolchain-funcs
+
+MY_PV="$(ver_rs 1- _)"
+
+DESCRIPTION="A system for large project software construction, simple to use and powerful"
+HOMEPAGE="https://boostorg.github.io/build/"
+SRC_URI="https://downloads.sourceforge.net/project/boost/boost/${PV}/boost_${MY_PV}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples python test"
+RESTRICT="test"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+       !<dev-libs/boost-1.35.0
+       !<=dev-util/boost-build-1.35.0-r1"
+DEPEND="${RDEPEND}
+       test? (
+               sys-apps/diffutils
+               ${PYTHON_DEPS}
+       )"
+
+REQUIRED_USE="
+       python? ( ${PYTHON_REQUIRED_USE} )
+       test? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/boost_${MY_PV}/tools/build/src"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-1.48.0-disable_python_rpath.patch"
+       "${FILESDIR}/${PN}-1.50.0-respect-c_ld-flags.patch"
+       "${FILESDIR}/${PN}-1.49.0-darwin-gentoo-toolchain.patch"
+       "${FILESDIR}/${PN}-1.52.0-darwin-no-python-framework.patch"
+       "${FILESDIR}/${PN}-1.55.0-ppc-aix.patch"
+       "${FILESDIR}/${PN}-1.62.0-sparc-no-default-flags.patch"
+       "${FILESDIR}/${PN}-1.66.0-add-none-feature-options.patch"
+)
+
+pkg_setup() {
+       if use python || use test; then
+               python-single-r1_pkg_setup
+       fi
+}
+
+src_unpack() {
+       tar xojf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build || die "unpacking tar failed"
+}
+
+src_prepare() {
+       default
+
+       pushd ../ >/dev/null || die
+       eapply "${FILESDIR}/${PN}-1.54.0-fix-test.patch"
+       popd >/dev/null || die
+
+       # Remove stripping option
+       # Fix python components build on multilib systems, bug #496446
+       cd "${S}/engine" || die
+       sed -i \
+               -e 's|-s\b||' \
+               -e "/libpython/s/lib ]/$(get_libdir) ]/" \
+               build.jam || die "sed failed"
+
+       # Force regeneration
+       rm jambase.c || die
+
+       # This patch allows us to fully control optimization
+       # and stripping flags when bjam is used as build-system
+       # We simply extend the optimization and debug-symbols feature
+       # with empty dummies called 'none'
+       cd "${S}" || die
+       sed -i \
+               -e 's/\(off speed space\)/\1 none/' \
+               -e 's/\(debug-symbols      : on off\)/\1 none/' \
+               tools/builtin.jam || die "sed failed"
+}
+
+src_configure() {
+       if use python; then
+               # replace versions by user-selected one (TODO: fix this when slot-op
+               # deps are available to always match the best version available)
+               sed -i \
+                       -e "s|27 26 25 24 23 22|${EPYTHON#python}|" \
+                       engine/build.jam || die "sed failed"
+       fi
+}
+
+src_compile() {
+       cd engine || die
+
+       local toolset
+
+       if [[ ${CHOST} == *-darwin* ]]; then
+               toolset=darwin
+       else
+               # Using boost's generic toolset here, which respects CC and CFLAGS
+               toolset=cc
+       fi
+
+       CC=$(tc-getCC) ./build.sh ${toolset} -d+2 $(use_with python python "${ESYSROOT}"/usr) || die "building bjam failed"
+}
+
+src_test() {
+       cd ../test || die
+
+       local -x TMP="${T}"
+
+       DO_DIFF="${EPREFIX}/usr/bin/diff" "${EPYTHON}" test_all.py
+
+       if [[ -s test_results.txt ]]; then
+               eerror "At least one test failed: $(<test_results.txt)"
+               die "tests failed"
+       fi
+}
+
+src_install() {
+       dobin engine/bin.*/{bjam,b2}
+
+       insinto /usr/share/boost-build
+       doins -r "${FILESDIR}/site-config.jam" \
+               ../boost-build.jam bootstrap.jam build-system.jam ../example/user-config.jam *.py \
+               build kernel options tools util
+
+       if ! use python; then
+               find "${ED}/usr/share/boost-build" -iname "*.py" -delete || die "removing experimental python files failed"
+       fi
+
+       dodoc ../notes/{changes,release_procedure,build_dir_option,relative_source_paths}.txt
+
+       if use examples; then
+               docinto examples
+               dodoc -r ../example/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+}
index 6bfb5adc51af92339675b69947fc88e7c8f30d3e..97ca81bb3800f091ca51d9f2057acf3b2cfc5523 100644 (file)
@@ -1,6 +1,10 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
+# David Seifert <soap@gentoo.org> (15 Apr 2019)
+# app-arch/zstd is not keyworded.
+dev-libs/boost zstd
+
 # Hans de Graaff <graaff@gentoo.org> (08 Apr 2019)
 # Obsolete ruby version, no newer versions keyworded or stable.
 dev-vcs/subversion ruby
index 633be51913806fe6516e38739dd4dfc18b998548..20d2dfc77ced2f61dccf618af61f31510e993afa 100644 (file)
 
 #--- END OF EXAMPLES ---
 
+# David Seifert <soap@gentoo.org> (15 Apr 2019)
+# Masked for testing, Bug #653878.
+>=dev-libs/boost-1.70.0
+>=dev-util/boost-build-1.70.0
+
 # Patrice Clement <monsieurp@gentoo.org> (14 Apr 2019)
 # Old, unmaintained and sometimes abandoned Java libraries/programs.
 # Removal in 30 days.