app-admin/qtpass: Version bump to 1.1.5 and add 9999
authorVladimir Pavljuchenko (SpiderX) <spiderx@spiderx.dp.ua>
Thu, 27 Oct 2016 16:58:37 +0000 (19:58 +0300)
committerMichael Palimaka <kensington@gentoo.org>
Sat, 5 Nov 2016 15:23:51 +0000 (02:23 +1100)
Gentoo-Bug: https://bugs.gentoo.org/572986

1. Bump to 1.1.5
2. EAPI 6
3. Remove dev-qt/qtsvg as not needed
4. Install man
5. Use default src_prepare (fix is in upstream)
6. Add 9999 version
7. Drop Qt4 support

Package-Manager: portage-2.3.0

app-admin/qtpass/Manifest
app-admin/qtpass/qtpass-1.1.5.ebuild [new file with mode: 0644]
app-admin/qtpass/qtpass-9999.ebuild [new file with mode: 0644]

index 62b807421ce8f8b599fedbacae7f98c4e15ee42d..e9b21b9d3cb9cab4c6093caa656477b6117508cc 100644 (file)
@@ -1,2 +1,3 @@
 DIST qtpass-1.0.5.tar.gz 636461 SHA256 0c07bd1eb9e5336c0225f891e5b9a9df103f218619cf7ec6311edf654e8db281 SHA512 e1b63f1058dc9c194f06376d52acbbb8594d429f4d7fe4ba27baed2cafe10b1c36137b3e33626c1bf33c7f3e1444e6fbe48fc66a83e0f7cd82f5b47f0193d178 WHIRLPOOL acb914d89bcd667343f648e38bb9eb316ebbf0b01f75686d3a7694e82eedd3e3f52ffc99f530bbe3ccbb6089ced727796924fcf48a94c071a3e20b27141b28df
 DIST qtpass-1.1.0.tar.gz 671525 SHA256 60b458062f54184057e55dbd9c93958a8bf845244ffd70b9cb31bf58697f0dc6 SHA512 da7439f2c18c46cbf4df15538210051ad60d036334e62a1c4f62d6c1ccff8e4327fb0c6030ed89f78ffd87b615fcaae8ed5552099ff8663bff713990216132ae WHIRLPOOL 4288ee76762c41a81fece4b72bacb1560b28d5681ce288f5e9b5fd9257fd778e4038fc0c75951bdb2a967afdf6ac66035fc716606b1ad6148834fc4ca81dfe45
+DIST qtpass-1.1.5.tar.gz 329958 SHA256 3ab26fdcaec72672557552e309bf3d8f3b8b9e3e0e9379b8c3343a7351597200 SHA512 fa1ab73c0de9d00581c2b8920e50f2110a2a9e4c3552c0468762cdfeaf982702126e3c727e029e82c61e6e44d01a7281b8acb5c26d5299f4ef25cd16a20ca1c0 WHIRLPOOL dc2f73b341735de0a9562ec298eedf1fc8543e0789420ef891da4237c01ed6795cd861af5700120da951b29158aa32429279789cc1796e84b64141fc6535afb6
diff --git a/app-admin/qtpass/qtpass-1.1.5.ebuild b/app-admin/qtpass/qtpass-1.1.5.ebuild
new file mode 100644 (file)
index 0000000..f788d5e
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_P="QtPass-${PV}"
+
+inherit qmake-utils
+
+DESCRIPTION="multi-platform GUI for pass, the standard unix password manager"
+HOMEPAGE="https://qtpass.org/"
+SRC_URI="https://github.com/IJHack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DOCS=( FAQ.md README.md CONTRIBUTING.md )
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="dev-qt/qtcore:5
+       dev-qt/qtgui:5[xcb]
+       dev-qt/qtwidgets:5
+       dev-qt/qtnetwork:5
+       app-admin/pass
+       net-misc/x11-ssh-askpass"
+DEPEND="${RDEPEND}
+       dev-qt/linguist-tools:5
+"
+
+src_configure() {
+       eqmake5 PREFIX="${D}"/usr
+}
+
+src_install() {
+       default
+
+       doman ${PN}.1
+
+       insinto /usr/share/applications
+       doins "${PN}.desktop"
+
+       newicon artwork/icon.svg "${PN}-icon.svg"
+}
diff --git a/app-admin/qtpass/qtpass-9999.ebuild b/app-admin/qtpass/qtpass-9999.ebuild
new file mode 100644 (file)
index 0000000..68a01da
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils git-r3
+
+DESCRIPTION="multi-platform GUI for pass, the standard unix password manager"
+HOMEPAGE="https://qtpass.org/"
+EGIT_REPO_URI="https://github.com/IJHack/${PN}.git"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+DOCS=( FAQ.md README.md CONTRIBUTING.md )
+
+RDEPEND="dev-qt/qtcore:5
+       dev-qt/qtgui:5[xcb]
+       dev-qt/qtwidgets:5
+       dev-qt/qtnetwork:5
+       app-admin/pass
+       net-misc/x11-ssh-askpass"
+DEPEND="${RDEPEND}
+       dev-qt/linguist-tools:5
+"
+
+src_configure() {
+       eqmake5 PREFIX="${D}"/usr
+}
+
+src_install() {
+       default
+
+       doman ${PN}.1
+
+       insinto /usr/share/applications
+       doins "${PN}.desktop"
+
+       newicon artwork/icon.svg "${PN}-icon.svg"
+}