dev-python/entrypoints: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 14:17:08 +0000 (15:17 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 14:37:49 +0000 (15:37 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/entrypoints/entrypoints-0.3-r1.ebuild

index da55a0a76990acf641a2d3bf01eae21b873169db..2f28407b7f56f586e72302554c1668af64db8eec 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=no
 PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7,8}} )
 
 inherit distutils-r1
@@ -15,9 +16,9 @@ LICENSE="BSD"
 SLOT="0"
 KEYWORDS="amd64 ~arm arm64 ~ia64 ~sparc ~x86"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' 'python2*')
        test? (
                dev-python/pytest[${PYTHON_USEDEP}]
@@ -25,8 +26,6 @@ DEPEND="
        )
 "
 
-RESTRICT="!test? ( test )"
-
 PATCHES=(
        "${FILESDIR}/${PN}"-0.2.1-init.py.patch
 )