dev-python/pylons: bump
authorIan Delaney <idella4@gentoo.org>
Wed, 12 Aug 2015 06:29:05 +0000 (14:29 +0800)
committerIan Delaney <idella4@gentoo.org>
Wed, 12 Aug 2015 06:34:49 +0000 (14:34 +0800)
Package-Manager: portage-2.2.20

dev-python/pylons/Manifest
dev-python/pylons/pylons-1.0.2.ebuild [new file with mode: 0644]

index 681f5d2b5b26112fe27ad0db4eae317b8e09f7f2..b4c321acfc7b54f1942662a4f557fcbc1ac62bdd 100644 (file)
@@ -1 +1,2 @@
 DIST Pylons-1.0.1.tar.gz 2299257 SHA256 7c22579516d92e6fcab3f9555b33fe7a259cc2e16d2fe414816c0138c91e8c0d SHA512 1b34541c912c914636fc7b0d358439a6705e5161a306a4bfa6a08cbc1ee4741cb3882afc9cae9a22d208f89f9648a4b7559304842339c8d6d75472f058a91ceb WHIRLPOOL 58019b223a0fc52f5cf7582a03ae7f5b25c29b88d3faff42c03ed5602f3fb2bc4bc9a4cce48d761109c2c7a4edc0b05ffcb100bf1bab70cf572f93c6da38d2c8
+DIST Pylons-1.0.2.tar.gz 187012 SHA256 918fd04b8bdb9515ebb8ccbb981df43276aeaf865a0d4cec81b392b3ac96874f SHA512 a57b6cd25486824dc3143b1202dc7c11ed5bbb5f5beba4359a1a491bb1611057976d36b0792037aabda3bc5ef87e12f3dc17a431609961c81a28632268570bb1 WHIRLPOOL 97e925456e443a5fe0512663460dc639d723d0c9ce922a5707bd3a41e01bc570e0f6411d0865e6f96138f43925fb9d68a609ba998d1760d5c72dce12106b76a9
diff --git a/dev-python/pylons/pylons-1.0.2.ebuild b/dev-python/pylons/pylons-1.0.2.ebuild
new file mode 100644 (file)
index 0000000..e7f874f
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Pylons"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pylons Web Framework"
+HOMEPAGE="http://pylonshq.com/ http://pypi.python.org/pypi/Pylons"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="genshi jinja test"
+
+RDEPEND=">=dev-python/beaker-1.5.4[${PYTHON_USEDEP}]
+               >=dev-python/decorator-3.3.2[${PYTHON_USEDEP}]
+               >=dev-python/formencode-1.2.4[${PYTHON_USEDEP}]
+               >=dev-python/mako-0.5.0[${PYTHON_USEDEP}]
+               >=dev-python/nose-1.1.2[${PYTHON_USEDEP}]
+               >=dev-python/paste-1.7.5.1[${PYTHON_USEDEP}]
+               >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
+               >=dev-python/pastescript-1.7.4.2[${PYTHON_USEDEP}]
+               >=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]
+               >=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
+               >=dev-python/simplejson-2.2.1[${PYTHON_USEDEP}]
+               >=dev-python/tempita-0.5.1[${PYTHON_USEDEP}]
+               >=dev-python/weberror-0.10.3[${PYTHON_USEDEP}]
+               dev-python/webhelpers[${PYTHON_USEDEP}]
+               >=dev-python/webob-1.1.1[${PYTHON_USEDEP}]
+               >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+               >=dev-python/markupsafe-0.15[${PYTHON_USEDEP}]
+       genshi? ( >=dev-python/genshi-0.6[${PYTHON_USEDEP}] )
+       jinja? ( >=dev-python/jinja-2[${PYTHON_USEDEP}] )"
+# Dependency on >=dev-python/coverage-2.85 and dev-python/genshi is not with Jython.
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( ${RDEPEND}
+               >=dev-python/coverage-2.85[${PYTHON_USEDEP}]
+       )"
+
+REQUIRED_USE="test? ( genshi jinja )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+       nosetests || die "Tests fail with ${EPYTHON}"
+}