dev-python/jellyfish: Bump to 0.7.2
authorMichał Górny <mgorny@gentoo.org>
Mon, 8 Jul 2019 07:48:48 +0000 (09:48 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 8 Jul 2019 08:19:50 +0000 (10:19 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/jellyfish/Manifest
dev-python/jellyfish/jellyfish-0.7.2.ebuild [new file with mode: 0644]

index cc79ad9cd5e462446226b4bb63081632cfd53012..4e8c43bffb892f77fb4192940144b4588d4a5e08 100644 (file)
@@ -1 +1,2 @@
 DIST jellyfish-0.7.1.tar.gz 131122 BLAKE2B c494e38d3101b1a7bfd295b80957d834bc3e475dac72bd9d81669466eb395e293faa41a581953250133d455d20ca71959414cabd73d5c3dea444ee39e4e8f973 SHA512 c8464171cead812f6dab8c61c74d83afafbf6451e7143e5be74400dffcf895be925a3628ac4fff47467b6dbf70b6d068daaf1c141b1846e53d5d19bed1617ca0
+DIST jellyfish-0.7.2.tar.gz 133320 BLAKE2B 094610c79e8c7f1caa94ff6c8f6936c3ff26c8d8ab8a7605c145e8293d1ebc28f5d057a603f7d8392811aea5d31a87ecb3e3d9eb682e2fd8a3222f23fbc7c3f7 SHA512 5fa19826a3adb16dea26855d733bd3e8ccce0c68652249f7bcc06f9b5d5ac36919152301c9afafdfca9877cef6614dccbe8e46a51ab41c1fed493374929c3367
diff --git a/dev-python/jellyfish/jellyfish-0.7.2.ebuild b/dev-python/jellyfish/jellyfish-0.7.2.ebuild
new file mode 100644 (file)
index 0000000..f3bfa93
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+DESCRIPTION="Python module for doing approximate and phonetic matching of strings"
+HOMEPAGE="https://github.com/jamesturk/jellyfish https://pypi.org/project/jellyfish/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? (
+               dev-python/pytest-runner[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/unicodecsv[${PYTHON_USEDEP}]
+       )
+"
+
+python_compile() {
+       esetup.py build_ext --inplace
+       esetup.py build
+}
+
+python_compile_all() {
+       if use doc; then
+               esetup.py build_sphinx
+               HTML_DOCS=( build/sphinx/html/. )
+       fi
+}
+
+python_test() {
+       py.test jellyfish/test.py || die "tests failed with ${EPYTHON}"
+}