dev-python/sphinxcontrib-napoleon: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 13:06:22 +0000 (14:06 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 13:06:22 +0000 (14:06 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/sphinxcontrib-napoleon/Manifest
dev-python/sphinxcontrib-napoleon/files/no_installed_tests.patch [deleted file]
dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.5.2.ebuild [deleted file]

index 6b550923dd542f2edc2b1035116c67fc10962fb3..e83efc79d0b5d73d1d5e5ff39d388c56a1cc046a 100644 (file)
@@ -1,2 +1 @@
-DIST sphinxcontrib-napoleon-0.5.2.tar.gz 24939 BLAKE2B 80735db4176019b164a60c6327600246949a6dd892c161d35ca8046ff669fdcd68661083bfdd94400b8e32a3eb89bfede31bc569df1b17a37ac28071392020bc SHA512 5f8d31c4ce66a042aa0c79ec06b7592539154bd7a397c1898db0cbed15b9891c908bb1d51334ef0b759e5d44ac99cf124616f0e4b3a1b1253f0f92312c949a8c
 DIST sphinxcontrib-napoleon-0.6.1.tar.gz 20057 BLAKE2B fe56c257af9433ee10dc92f7a028d581ce0783143f1d187cedbc226a72d3a2af9b185cb528549b80f77749aea15484bdbea5d0bdb7d5b087ac952ed3b855e1ad SHA512 1809fcadf964622bd75cc3ae17aaad467b7003f82e6df4de039a0ba86daa5c5b199af0c185129e79d3c4f8738c0d6c2411950888969fee3bb32ecc8cdfbc84b0
diff --git a/dev-python/sphinxcontrib-napoleon/files/no_installed_tests.patch b/dev-python/sphinxcontrib-napoleon/files/no_installed_tests.patch
deleted file mode 100644 (file)
index 20ba790..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py.orig      2016-08-03 16:43:35.775261808 +0200
-+++ setup.py   2016-08-03 16:43:56.126054227 +0200
-@@ -43,7 +43,7 @@
-         'Framework :: Sphinx :: Extension',
-     ],
-     platforms='any',
--    packages=find_packages(),
-+    packages=["sphinxcontrib"],
-     include_package_data=True,
-     install_requires=reqs,
-     test_suite='nose.collector',
diff --git a/dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.5.2.ebuild b/dev-python/sphinxcontrib-napoleon/sphinxcontrib-napoleon-0.5.2.ebuild
deleted file mode 100644 (file)
index 41e94f4..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_5 )
-
-inherit distutils-r1
-
-DESCRIPTION="Allow a different format in dosctrings for better clarity"
-HOMEPAGE="https://pypi.org/project/sphinxcontrib-napoleon/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=test
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
-       >=dev-python/pockets-0.3[${PYTHON_USEDEP}]
-       test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
-                       >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
-                       >=dev-python/flake8-2.0[${PYTHON_USEDEP}]
-                       >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
-                       >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
-                       >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
-       )
-"
-src_prepare() {
-       epatch "${FILESDIR}/no_installed_tests.patch" || die
-}
-
-python_test() {
-       nosetests tests || die "tests failed with ${EPYTHON}"
-}