www-servers/nginx-unit: Bump to version 1.12
authorRalph Seichter <github@seichter.de>
Thu, 10 Oct 2019 19:00:26 +0000 (21:00 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 11 Oct 2019 14:16:29 +0000 (17:16 +0300)
Closes: https://bugs.gentoo.org/696742
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Ralph Seichter <gentoo@seichter.de>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
www-servers/nginx-unit/Manifest
www-servers/nginx-unit/nginx-unit-1.12.0.ebuild [new file with mode: 0644]

index 2ee21d3c14f4a57dc1cd2f14d81ef537c61aa6f7..27c625175287e4c50c45a3320abe6700c91cf9eb 100644 (file)
@@ -1,3 +1,4 @@
 DIST nginx-unit-1.10.0.tar.gz 564348 BLAKE2B 82339422b4b3b696ff4bbb216d6c0d54f046531aa56f6e0f5602a9bbe18db878b6bc9c9e9b1513be0cee3197f288549d8a6f826bf69ffbb91fc35757775bde4d SHA512 da2b248ba22e5d46fa1c8c21041a875655fad0e1a09683c58cb5bb33ed0a671a921c7a13f99269f0574da02d0efaeff0233abc901e4e333f3f7ac9383334c781
 DIST nginx-unit-1.11.0.tar.gz 681333 BLAKE2B 4e727f1b0bd5a593ea360b4125173bc6b3694b953fa2c775ce4f7112bd9f2df131d4bfd4e01cb653c08a9cdacc560a6961b8926c797ea2ce7d6c32a7e4f7f7e2 SHA512 894093385137bc188c50b86540182007bac1740a063359f494c1984687352eccb879f7d6b7b6623d5702cce3c793f12c60a2dfab94bcf9cb817b80a1577409d9
+DIST nginx-unit-1.12.0.tar.gz 681661 BLAKE2B 1e497172a37fdcd33d0ced5b97675bff42f4cadab2f9363316e667c90c8b4dc4b43f4b8d5cff9f547daa7e92d532550434907515134a5c958586f1822beea749 SHA512 a55a084ed6e1cd3f784bd81571772ca29ca9a0d19089c9bb74c88258d2e1ef872978219c47b6dc2610711ae1aa95ef68ddb77f45747a2eacdd9d92c6f8fee28b
 DIST nginx-unit-1.8.0.tar.gz 511226 BLAKE2B e396b27954840a5f1ad3a4cd9501a5e5fe769a754c51043da784a2c4596e6acc33089f495bf412a0db086e5c715a51292c7dece004a6512564421a431b6c339e SHA512 1d0ad05343ff70aff4c6e221a36c20df95fa2e2262ae5c69963a9bcb9ef883151e8a2fa9fef29f43ac5489aa5cbb3e9dfd10cf5e7f6d7a98742b490ebf3a0413
diff --git a/www-servers/nginx-unit/nginx-unit-1.12.0.ebuild b/www-servers/nginx-unit/nginx-unit-1.12.0.ebuild
new file mode 100644 (file)
index 0000000..72e543d
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python2_7 python3_{5,6,7})
+
+inherit python-single-r1
+
+MY_P="unit-${PV}"
+DESCRIPTION="A dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php5-6 php7-1 php7-2 php7-3"
+IUSE="${MY_USE} ${MY_USE_PHP}"
+REQUIRED_USE="|| ( ${IUSE} )
+       python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+       php5-6? ( dev-lang/php:5.6[embed] )
+       php7-1? ( dev-lang/php:7.1[embed] )
+       php7-2? ( dev-lang/php:7.2[embed] )
+       php7-3? ( dev-lang/php:7.3[embed] )
+       python? ( ${PYTHON_DEPS} )
+       ruby? ( dev-lang/ruby:= )"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+       ./configure \
+               --control=unix:/run/${PN}.sock \
+               --ld-opt="${LDFLAGS}" \
+               --log=/var/log/${PN} \
+               --modules=$(get_libdir)/${PN} \
+               --pid=/run/${PN}.pid \
+               --prefix=/usr \
+               --state=/var/lib/${PN} || die "Core configuration failed"
+       for flag in ${MY_USE} ; do
+               if use ${flag} ; then
+                       ./configure ${flag} || die "Module configuration failed: ${flag}"
+               fi
+       done
+       for flag in ${MY_USE_PHP} ; do
+               if use ${flag} ; then
+                       local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+                       ./configure php \
+                               --module=${flag} \
+                               --config=${php_slot}/bin/php-config \
+                               --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+               fi
+       done
+}
+
+src_install() {
+       default
+       diropts -m 0770
+       keepdir /var/lib/${PN}
+       newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}