dev-python/marshmallow: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 21:19:35 +0000 (22:19 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 21:19:35 +0000 (22:19 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/marshmallow/Manifest
dev-python/marshmallow/marshmallow-2.20.2.ebuild [deleted file]

index c30618831c6c53ca898ba3d75e2fa6e7656dee82..4ffd8f6ec4b8eea2d73c993952390526909b0658 100644 (file)
@@ -1,3 +1,2 @@
-DIST marshmallow-2.20.2.tar.gz 152437 BLAKE2B 0d31537051c45bad52d922439d1cb9d69fc4a4bc2767d6a13bfe32a9edc978cadf9b1c508ae51532f5661291f32ed4b7c5e54f5fcd092eb4ebd7d3045521e9b8 SHA512 05511aafa978377152ea8ea1b70dd5558782bf634df5ae52453bfa65c7ec9270a12cd7a32e11872808a3289cfab2ef0380e129e84878511872e7cc95b0792453
 DIST marshmallow-2.20.5.tar.gz 152733 BLAKE2B ba509624e3715ace53eeb1a835f533172d676b3645ae3226c6da3727dafef7084bde896f3a66459112d599e3e422d600d150934313b813fea9d819658ce3b4bf SHA512 a02b6a3341d2cd08174937112eba2f69a07de59054a088eef64ac12703699e2b6f561ce76ebc0cb43334056f02f3898098bb0d3501ae8a1b6350f9a168eb3355
 DIST marshmallow-3.0.1.tar.gz 168186 BLAKE2B 6c89fed45c144a855c692bee39390e1c80b2977274acb704095e76567e6ed00643704473f95abac7fabb4c1d1d96b90cb9a6fe3a127a09a0d2a4c72c02358baf SHA512 085a7e9b265bb86232222e4decb32fa172d62bca3ba3c5303f12715be1b0ab6553b1978e28db520a6a7a25778915c770ac83c607bdebf5e4d26746cd69f2d555
diff --git a/dev-python/marshmallow/marshmallow-2.20.2.ebuild b/dev-python/marshmallow/marshmallow-2.20.2.ebuild
deleted file mode 100644 (file)
index 55c9041..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A lightweight library for converting complex datatypes to and from native Python datatypes."
-HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/python-dateutil[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/simplejson[${PYTHON_USEDEP}]
-       )"
-
-src_prepare() {
-       distutils-r1_src_prepare
-}
-
-python_test() {
-       if [[ ${EPYTHON} == python2.7 ]]; then
-               rm -rf tests/test_py3 || die
-       fi
-       py.test -v || die "tests failed under ${EPYTHON}"
-}