dev-python/python-glanceclient: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 21:01:28 +0000 (22:01 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 21:11:08 +0000 (22:11 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/python-glanceclient/Manifest
dev-python/python-glanceclient/python-glanceclient-2.13.1.ebuild [deleted file]

index c0a0592631a64e3717216c51c426314eeb80df92..9e7468a4d92b09058602e12fa949752e2f00648c 100644 (file)
@@ -1,2 +1 @@
-DIST python-glanceclient-2.13.1.tar.gz 187298 BLAKE2B e2fa34ea7840404e183fbb77592f656b296d54942581b2e1dda71285f791cf7f7d5b3b6ef2da28deb4e314f1d35395548e923f548854b7ad3ef4aa50ad000d62 SHA512 deb8454aea8b2c231604663fac2f6515e3cd6e86dc1cf3cd2174ba2e35f9d605bf162f5a089d80f52da11f97c540f5c160b96864b85d7535463ec170cba81689
 DIST python-glanceclient-2.16.0.tar.gz 189395 BLAKE2B 9de8b162c1eb5bfb44700f41cbdcd4f8a983d8c7bd7b281df09db67df6a0de5dee905330f03c967be9e1c3b2aaa379e4c8594f7f4cdbb34870a1e87cb7ccaf1f SHA512 b853f529752247873d9f319d4ec6f4cabc89ee4c26a0c1013e7609fc38e3c9f68d774b3682166e8155e21572a0a011eb6859a84c253ca9f7a9b8b1ccf79b5322
diff --git a/dev-python/python-glanceclient/python-glanceclient-2.13.1.ebuild b/dev-python/python-glanceclient/python-glanceclient-2.13.1.ebuild
deleted file mode 100644 (file)
index e23ed64..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Glance API"
-HOMEPAGE="https://github.com/openstack/python-glanceclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="test? ( doc )"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
-               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/os-client-config-1.28.0[${PYTHON_USEDEP}]
-               >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
-               >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
-               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
-               >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
-               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-               >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
-       )
-       doc? (
-               >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
-               !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="
-       ${CDEPEND}
-       >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
-       <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
-       >=dev-python/keystoneauth-3.6.2[${PYTHON_USEDEP}]
-       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
-       >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
-       <dev-python/warlock-2[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
-       >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
-       >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
-       sed -e 's:intersphinx_mapping:_&:' -i doc/source/conf.py || die
-       sed -i '/^hacking/d' test-requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && esetup.py build_sphinx
-}
-
-python_test() {
-       testr init
-       testr run || die "testsuite failed under ${EPYTHON}"
-       flake8 tests && einfo "run flake8 over tests folder passed" || die
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/build/html/. )
-       distutils-r1_python_install_all
-}