dev-libs/stfl: Drop old
authorPacho Ramos <pacho@gentoo.org>
Tue, 18 Oct 2016 19:22:31 +0000 (21:22 +0200)
committerPacho Ramos <pacho@gentoo.org>
Tue, 18 Oct 2016 19:26:32 +0000 (21:26 +0200)
Package-Manager: portage-2.3.1

dev-libs/stfl/Manifest
dev-libs/stfl/stfl-0.22-r2.ebuild [deleted file]

index 68089c4311045f838a66074a7f58aa7fc5147bcb..285d8a9567ec7600925e3d9f4d59a36ccb0f2297 100644 (file)
@@ -1,3 +1,2 @@
-DIST stfl-0.22.tar.gz 41412 SHA256 2dddafd331e61ad04baf1251ccecb3a69feaf99880dd75155be8423c1cc55418 SHA512 dab2335ef00b65d00abda2a51fb5c667b48864b02ee82abee049f15fd9e2f272f21ec80d4a6cdbb5fc5882239ba28964912e4c0b641b2e83a7ab3bd7f94415bb WHIRLPOOL e1fdd9754f8d6bed3c43a8d19e128565efac36ead413836fe02ee97cb6ba9c3ac5ca2a2e5c7784389e0e8671dbf49286d2a3c746f31b406e511bf6942efce39e
 DIST stfl-0.23.tar.gz 43941 SHA256 e75ed8427905ad50faf43ed5fefd0cf7b16ee0c1ca87e15d33e360bb92aedfde SHA512 02a7323740364acac4063d002775d04358bc9f98d8df4d83ec9dcdc9d9f46840be1cab0d2526c8cdc7a441784ec95100792edd1bbd1fa2365ce20ef4141a0e6e WHIRLPOOL 6331623402ae5a7df97df6c135b043e8c9b327de78ab2916e122489bdf1108871aef7772c016b5f567f8a00dca1f4274fce4add3d2d9a625f5aca911301c9730
 DIST stfl-0.24.tar.gz 45585 SHA256 d4a7aa181a475aaf8a8914a8ccb2a7ff28919d4c8c0f8a061e17a0c36869c090 SHA512 95df4574b1bc32d795751156dc5b93afbca3ba241607a3a55210c89dda61b9a26ad574bb5f729a0158c9052235dbf63d6c58b38e7f1061d14ab7062af6150fa0 WHIRLPOOL 76545f41802a5f019ee44598368958a13551c3ed70747f45da88d61bc9ba882e514659b3c8f47805a7c199229078abc22ac5a79680b803244bfe8e29a081f10e
diff --git a/dev-libs/stfl/stfl-0.22-r2.ebuild b/dev-libs/stfl/stfl-0.22-r2.ebuild
deleted file mode 100644 (file)
index 13b6d88..0000000
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
-
-inherit eutils multilib perl-module python toolchain-funcs
-
-DESCRIPTION="A library which implements a curses-based widget set for text terminals"
-HOMEPAGE="http://www.clifford.at/stfl/"
-SRC_URI="http://www.clifford.at/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-
-IUSE="examples perl python ruby static-libs"
-
-COMMON_DEPEND="sys-libs/ncurses[unicode]
-       perl? ( dev-lang/perl )
-       ruby? ( dev-lang/ruby )
-       python? ( dev-lang/python )"
-
-DEPEND="${COMMON_DEPEND}
-       perl? ( dev-lang/swig )
-       python? ( >=dev-lang/swig-1.3.40 )
-       ruby? ( dev-lang/swig )"
-
-RDEPEND="${COMMON_DEPEND}"
-
-pkg_setup() {
-       use python && python_pkg_setup
-}
-
-src_prepare() {
-       sed -i \
-               -e 's/-Os -ggdb//' \
-               -e 's/^\(all:.*\) example/\1/' \
-               -e 's/$(CC) -shared/$(CC) $(LDFLAGS) -shared/' \
-               -e 's/ -o $@ $(LDLIBS) $^/ $^ $(LDLIBS) -o $@/' \
-               -e 's/-lncursesw/-lncursesw -pthread/' \
-               Makefile || die "sed failed"
-
-       if ! use static-libs ; then
-               sed -i -e "/install .* libstfl.a/d" Makefile || die
-       fi
-
-       epatch "${FILESDIR}"/${PN}-0.21-python.patch
-       epatch "${FILESDIR}"/${P}-soname-symlink.patch
-       epatch "${FILESDIR}"/${P}-ruby-sharedlib.patch
-
-       if use perl ; then
-               echo "FOUND_PERL5=1" >> Makefile.cfg
-       else
-               echo "FOUND_PERL5=0" >> Makefile.cfg
-       fi
-
-       if use ruby ; then
-               echo "FOUND_RUBY=1" >> Makefile.cfg
-       else
-               echo "FOUND_RUBY=0" >> Makefile.cfg
-       fi
-
-       echo "FOUND_PYTHON=0" >> Makefile.cfg
-}
-
-src_configure() { :; }
-
-src_compile() {
-       emake CC="$(tc-getCC)"
-
-       if use python ; then
-               python_copy_sources python
-
-               # Based on code from python/Makefile.snippet.
-               building() {
-                       echo swig -python -threads stfl.i
-                       swig -python -threads stfl.i
-                       echo "$(tc-getCC)" ${CFLAGS} ${LDFLAGS} -shared -pthread -fPIC stfl_wrap.c -I$(python_get_includedir) -I.. ../libstfl.so.${PV} -lncursesw -o _stfl.so
-                       "$(tc-getCC)" ${CFLAGS} ${LDFLAGS} -shared -pthread -fPIC stfl_wrap.c -I$(python_get_includedir) -I.. ../libstfl.so.${PV} -lncursesw -o _stfl.so
-               }
-               python_execute_function -s --source-dir python building
-       fi
-}
-
-src_install() {
-       emake prefix="/usr" DESTDIR="${D}" libdir="$(get_libdir)" install
-
-       if use python ; then
-               installation() {
-                       insinto $(python_get_sitedir)
-                       doins stfl.py _stfl.so
-               }
-               python_execute_function -s --source-dir python installation
-       fi
-
-       dodoc README
-
-       local exdir="/usr/share/doc/${PF}/examples"
-       if use examples ; then
-               insinto ${exdir}
-               doins example.{c,stfl}
-               insinto  ${exdir}/python
-               doins python/example.py
-               if use perl ; then
-                       insinto ${exdir}/perl
-                       doins perl5/example.pl
-               fi
-               if use ruby ; then
-                       insinto ${exdir}/ruby
-                       doins ruby/example.rb
-               fi
-       fi
-
-       perl_delete_localpod
-}
-
-pkg_postinst() {
-       use python && python_mod_optimize stfl.py
-}
-
-pkg_postrm() {
-       use python && python_mod_cleanup stfl.py
-}