net-misc/youtube-dl: Old
authorJeroen Roovers <jer@gentoo.org>
Sun, 20 Jan 2019 19:58:58 +0000 (20:58 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sun, 20 Jan 2019 19:59:14 +0000 (20:59 +0100)
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-misc/youtube-dl/Manifest
net-misc/youtube-dl/youtube-dl-2019.01.10.ebuild [deleted file]
net-misc/youtube-dl/youtube-dl-2019.01.16.ebuild [deleted file]

index d858837404d801843899fc2818f246ad6a4c9594..4b877077246f00e524b7b2079895eca111de38f7 100644 (file)
@@ -1,3 +1 @@
-DIST youtube-dl-2019.01.10.tar.gz 3085961 BLAKE2B 938fe458a22f1c02c5e420ed43bc65247b7992e90d224891e2f5c8fb6410a0fba62dedd035a37b0e8c42a7dadc8082a26c97fb3f192a02df8795c9cfac6c6a42 SHA512 86c86688bf9120b56a0cda54ca4c8fef20f7afeea38a80b44d5aa77958b80ac4605b8de9666668297d0a9244693b17dcdfd85ddacc8990b179bd942c4d7158f2
-DIST youtube-dl-2019.01.16.tar.gz 3089080 BLAKE2B 9d4038565582bc63cf45eef97ea81ba86268f98d7a2230632bc300da8fd06432f90466a6efb2d7c43f13728af30f1df5b170c3fa710093e16b47f05257bcd6e3 SHA512 fafcd820248bdfbd70eddf98ab545fc6587ccbd64a3fac498985514ac7021a9635f32a5d0e52a5d46eb78b25b38b67a01b4d5bf3181bfadecd68b08b55e13ace
 DIST youtube-dl-2019.01.17.tar.gz 3088912 BLAKE2B 6cd46442d78126b3428135fcb820eb02bb2d567fe41fbfefcd80fc68a9ece0faaf2aa4981e31c619c3be1f789a9539236b1a71e72490c4ee667953837b25f0e5 SHA512 b8e81c2b2ec284033a5a92f49a965375d681d92435bc0402bb891b443f94d1321716a15717fe4e3c1fbc54ec610445282c52c18c046e140dd53731560230bd3f
diff --git a/net-misc/youtube-dl/youtube-dl-2019.01.10.ebuild b/net-misc/youtube-dl/youtube-dl-2019.01.10.ebuild
deleted file mode 100644 (file)
index c26955b..0000000
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
-inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
-
-DESCRIPTION="Download videos from YouTube.com (and more sites...)"
-HOMEPAGE="https://rg3.github.com/youtube-dl/"
-SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="+offensive test"
-
-RDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-"
-DEPEND="
-       ${RDEPEND}
-       test? ( dev-python/nose[coverage(+)] )
-"
-
-S="${WORKDIR}/${PN}"
-
-python_prepare_all() {
-       if ! use offensive; then
-               sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
-                       youtube_dl/version.py || die
-               # these have single line import statements
-               local xxx=(
-                       alphaporno anysex behindkink camwithher chaturbate eporner
-                       eroprofile extremetube foxgay goshgay hellporno hentaistigma
-                       hornbunny keezmovies lovehomeporn mofosex myvidster porn91 porncom
-                       pornflip pornhd pornotube pornovoisines pornoxo ruleporn sexu
-                       slutload spankbang spankwire sunporno thisav vporn watchindianporn
-                       xbef xnxx xtube xvideos xxxymovies youjizz youporn
-               )
-               # these have multi-line import statements
-               local mxxx=(
-                       drtuber fourtube motherless pornhub redtube tnaflix tube8 xhamster
-               )
-               # do single line imports
-               sed -i \
-                       -e $( printf '/%s/d;' ${xxx[@]} ) \
-                       youtube_dl/extractor/extractors.py \
-                       || die
-
-               # do multiple line imports
-               sed -i \
-                       -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
-                       youtube_dl/extractor/extractors.py \
-                       || die
-
-               sed -i \
-                       -e $( printf '/%s/d;' ${mxxx[@]} ) \
-                       youtube_dl/extractor/generic.py \
-                       || die
-
-               rm \
-                       $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
-                       $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
-                       test/test_age_restriction.py \
-                       || die
-       fi
-
-       eapply_user
-
-       distutils-r1_python_prepare_all
-}
-
-src_compile() {
-       distutils-r1_src_compile
-}
-
-python_test() {
-       emake test
-}
-
-python_install_all() {
-       dodoc README.txt
-       doman ${PN}.1
-
-       newbashcomp ${PN}.bash-completion ${PN}
-
-       insinto /usr/share/zsh/site-functions
-       newins ${PN}.zsh _${PN}
-
-       insinto /usr/share/fish/vendor_completions.d
-       doins ${PN}.fish
-
-       distutils-r1_python_install_all
-
-       rm -r "${ED}"/usr/etc || die
-       rm -r "${ED}"/usr/share/doc/youtube_dl || die
-}
-
-pkg_postinst() {
-       elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
-       elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
-       elog
-       elog "${PN} works fine on its own on most sites. However, if you want"
-       elog "to convert video/audio, you'll need avconf (media-video/libav) or"
-       elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
-       elog "videos can be retrieved in a higher quality format without sound."
-       elog "${PN} will detect whether avconv/ffmpeg is present and"
-       elog "automatically pick the best option."
-       elog
-       elog "Videos or video formats streamed via RTMP protocol can only be"
-       elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
-       elog "Downloading MMS and RTSP videos requires either mplayer"
-       elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
-       elog
-       elog "If you want ${PN} to embed thumbnails from the metadata into the"
-       elog "resulting MP4 files, consider installing media-video/atomicparsley"
-}
diff --git a/net-misc/youtube-dl/youtube-dl-2019.01.16.ebuild b/net-misc/youtube-dl/youtube-dl-2019.01.16.ebuild
deleted file mode 100644 (file)
index 6ef55f5..0000000
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
-inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
-
-DESCRIPTION="Download videos from YouTube.com (and more sites...)"
-HOMEPAGE="https://rg3.github.com/youtube-dl/"
-SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="+offensive test"
-
-RDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-"
-DEPEND="
-       ${RDEPEND}
-       test? ( dev-python/nose[coverage(+)] )
-"
-
-S="${WORKDIR}/${PN}"
-
-python_prepare_all() {
-       if ! use offensive; then
-               sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
-                       youtube_dl/version.py || die
-               # these have single line import statements
-               local xxx=(
-                       alphaporno anysex behindkink camwithher chaturbate eporner
-                       eroprofile extremetube foxgay goshgay hellporno hentaistigma
-                       hornbunny keezmovies lovehomeporn mofosex myvidster porn91 porncom
-                       pornflip pornhd pornotube pornovoisines pornoxo ruleporn sexu
-                       slutload spankbang spankwire sunporno thisav vporn watchindianporn
-                       xbef xnxx xtube xvideos xxxymovies youjizz youporn
-               )
-               # these have multi-line import statements
-               local mxxx=(
-                       drtuber fourtube motherless pornhub redtube tnaflix tube8 xhamster
-               )
-               # do single line imports
-               sed -i \
-                       -e $( printf '/%s/d;' ${xxx[@]} ) \
-                       youtube_dl/extractor/extractors.py \
-                       || die
-
-               # do multiple line imports
-               sed -i \
-                       -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
-                       youtube_dl/extractor/extractors.py \
-                       || die
-
-               sed -i \
-                       -e $( printf '/%s/d;' ${mxxx[@]} ) \
-                       youtube_dl/extractor/generic.py \
-                       || die
-
-               rm \
-                       $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
-                       $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
-                       test/test_age_restriction.py \
-                       || die
-       fi
-
-       eapply_user
-
-       distutils-r1_python_prepare_all
-}
-
-src_compile() {
-       distutils-r1_src_compile
-}
-
-python_test() {
-       emake test
-}
-
-python_install_all() {
-       dodoc README.txt
-       doman ${PN}.1
-
-       newbashcomp ${PN}.bash-completion ${PN}
-
-       insinto /usr/share/zsh/site-functions
-       newins ${PN}.zsh _${PN}
-
-       insinto /usr/share/fish/vendor_completions.d
-       doins ${PN}.fish
-
-       distutils-r1_python_install_all
-
-       rm -r "${ED}"/usr/etc || die
-       rm -r "${ED}"/usr/share/doc/youtube_dl || die
-}
-
-pkg_postinst() {
-       elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
-       elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
-       elog
-       elog "${PN} works fine on its own on most sites. However, if you want"
-       elog "to convert video/audio, you'll need avconf (media-video/libav) or"
-       elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
-       elog "videos can be retrieved in a higher quality format without sound."
-       elog "${PN} will detect whether avconv/ffmpeg is present and"
-       elog "automatically pick the best option."
-       elog
-       elog "Videos or video formats streamed via RTMP protocol can only be"
-       elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
-       elog "Downloading MMS and RTSP videos requires either mplayer"
-       elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
-       elog
-       elog "If you want ${PN} to embed thumbnails from the metadata into the"
-       elog "resulting MP4 files, consider installing media-video/atomicparsley"
-}