dev-util/dwarves: Switch to python3
authorMichal Privoznik <mprivozn@redhat.com>
Mon, 3 Jun 2019 08:36:21 +0000 (10:36 +0200)
committerMatthias Schwarzott <zzam@gentoo.org>
Wed, 5 Jun 2019 19:44:06 +0000 (21:44 +0200)
In the upstream commit of 139a3b337381c dwarves switched to
python3. Update our ebuild to reflect that.

Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
Signed-off-by: Matthias Schwarzott <zzam@gentoo.org>
dev-util/dwarves/dwarves-9999.ebuild

index 247fa28197448ea82efa7917989ddbf77e83b463..ad35a947177e36decfea9bfb4cfec651dbce801b 100644 (file)
@@ -5,7 +5,7 @@ EAPI=6
 
 EGIT_REPO_URI="https://git.kernel.org/pub/scm/devel/pahole/pahole.git"
 
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_6 )
 inherit multilib cmake-utils git-r3 python-single-r1
 
 DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
@@ -34,6 +34,4 @@ src_test() { :; }
 
 src_install() {
        cmake-utils_src_install
-       python_fix_shebang "${D}"/usr/bin/ostra-cg \
-               "${D}"/usr/share/dwarves/runtime/python/ostra.py
 }