app-admin/pwman3: new package
authorOz N Tiram <oz.tiram@gmail.com>
Wed, 5 Sep 2018 12:11:56 +0000 (14:11 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 13 Sep 2018 07:55:49 +0000 (09:55 +0200)
Pwman3 is a lightweight password-manager with multiple database
backends. Pwman3 is written in Python.

Package-Manager: Portage-2.3.40, Repoman-2.3.9
Closes: https://github.com/gentoo/gentoo/pull/9375

app-admin/pwman3/Manifest [new file with mode: 0644]
app-admin/pwman3/metadata.xml [new file with mode: 0644]
app-admin/pwman3/pwman3-0.9.11.ebuild [new file with mode: 0644]

diff --git a/app-admin/pwman3/Manifest b/app-admin/pwman3/Manifest
new file mode 100644 (file)
index 0000000..66153c9
--- /dev/null
@@ -0,0 +1 @@
+DIST pwman3-0.9.11.tar.gz 74364 BLAKE2B 9544b692e8853b7fb8e1b4d51093e72e04f8d82888a9278c94aaa27716026b348bb16f0fa9c52af2144395a4ffb242c8a48fc34252890e68477d2e3a70ea4a88 SHA512 2aa5a7b4d810d1bbc6aea34b728f89190570cbfbedc33f45cc1aa4d737ebbb9e993d2d372b44f956d5cdbc07f911f289fd77d7df167100e820455650f5b3e46a
diff --git a/app-admin/pwman3/metadata.xml b/app-admin/pwman3/metadata.xml
new file mode 100644 (file)
index 0000000..9bb7c28
--- /dev/null
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+       <name>Oz Tiram</name>
+       <email>oz.tiram@gmail.com</email>
+</maintainer>
+<maintainer type="project">
+       <email>proxy-maint@gentoo.org</email>
+       <name>Proxy Maintainers</name>
+</maintainer>
+<use>
+       <flag name="mongodb">Add support for MongoDB</flag>
+</use>
+<longdescription lang="en">
+       A lightweight command line password manager, which can use different
+       databases to store your passwords (currently, SQLite, MySQL, Postgresql
+       and MongoDB are supported). Pwman3 can also copy passwords to the
+       clipboard without exposing them. Besides managing and storing passwords,
+       Pwman3 can also generate passwords using different algorithms.
+       Per default pwman3 uses a strong AES encryption algorithm to store the
+       data.
+</longdescription>
+<upstream>
+       <remote-id type="github">pwman3/pwman3</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-admin/pwman3/pwman3-0.9.11.ebuild b/app-admin/pwman3/pwman3-0.9.11.ebuild
new file mode 100644 (file)
index 0000000..6fb41c3
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_5 python3_6 )
+PYTHON_REQ_USE="sqlite?"
+inherit distutils-r1
+
+DESCRIPTION="A lightweight password-manager with multiple database backends"
+HOMEPAGE="https://pwman3.github.io"
+SRC_URI="https://github.com/pwman3/pwman3/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="mongodb mysql postgres +sqlite test"
+
+COMMON="
+       >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
+       >=dev-python/colorama-0.3.0[${PYTHON_USEDEP}]
+       "
+
+DEPEND="
+       ${COMMON}
+       test? ( dev-python/pexpect[${PYTHON_USEDEP}] )
+       "
+
+RDEPEND="
+       ${COMMON}
+       mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
+       mysql? ( dev-python/pymysql[${PYTHON_USEDEP}] )
+       postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )
+       "
+
+python_test() {
+       esetup.py test
+}