dev-python/setuptools: Sync the live ebuild (nobody cares about)
authorMichał Górny <mgorny@gentoo.org>
Sat, 9 Feb 2019 07:39:14 +0000 (08:39 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 9 Feb 2019 08:48:03 +0000 (09:48 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/setuptools/setuptools-9999.ebuild

index ffd124714700db3831506b7f4b9720c8b617d501..d67bd927712b1af00a8a2a1fecd3b435b1d88b04 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
 PYTHON_REQ_USE="xml(+)"
 
@@ -12,7 +12,7 @@ if [[ ${PV} == "9999" ]]; then
        inherit git-r3
 else
        SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-       KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+       KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 fi
 
 DESCRIPTION="Collection of extensions to Distutils"
@@ -27,12 +27,13 @@ RDEPEND="
 DEPEND="${RDEPEND}
        app-arch/unzip
        test? (
+               dev-python/mock[${PYTHON_USEDEP}]
                dev-python/pip[${PYTHON_USEDEP}]
-               >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
-               dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+               >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
+               <dev-python/pytest-4
                dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
-               >=dev-python/backports-unittest-mock-1.2[${PYTHON_USEDEP}]
                dev-python/wheel[${PYTHON_USEDEP}]
+               virtual/python-futures[${PYTHON_USEDEP}]
        )
 "
 PDEPEND="
@@ -61,7 +62,7 @@ python_prepare_all() {
 python_test() {
        # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
        # It tries to sandbox the test in a tempdir
-       HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
+       HOME="${PWD}" pytest -vv ${PN} || die "Tests failed under ${EPYTHON}"
 }
 
 python_install() {